Firmware Upgrade 4.6.415145.35 - S50 Pro+ May. 06. 2022

This article summarizes the changes for the newest S50 Pro+ firmware release on April 28.2022.

What’s New:

  1. Improved OLED display
  2. Add preset EQ, Flat/Classic/Pop/Rock/Jazz/Vocal
  3. Adjusted default volume step to 5
  4. Adjusted minimum MXV to 30
  5. Add extra IR code for power on and power off
  6. Will reboot the device and enter WiFi mode when the sleep timer is out, to avoid the system not responding on standby.
  7. Show mute image instead of blinking 00 when muted
  8. Will keep the last power state when power is lost and resume
  9. Add BLE appendix for BLE device name to distinguish with classic Bluetooth
    Sync VB settings when set in ACPWorkbench
  10. Fixed, can’t switch to LINE-IN mode on boot
  11. Fixed, used treble value for bass on boot
  12. Fixed, SPDIF input voltage level
  13. Fixed, the OPTICAL input state is incorrect when switching source out and back
  14. Fixed, the SPDIF/I2S signal is not stopped when the system standby
  15. Fixed, system detected silence when the input level is low
  16. Fixed, some devices have a beep sound

April 30.2022 Update

  1. Support gapless playback
  2. Http API for playing notification(Smart Home)
  1. Fixed, http API reboot not working

Web Player New Features:

  1. Some improvements in Personal Radio and Audio Settings
  2. Personal radio
  3. Audio settings
  4. Need password for the whole page
  5. Set title for page


  1. Fixed the bug that S50 Pro+ can’t power on after the update.

I updated S50 pro + today, but while playing tracks from Spotify, Qobuz, Tidal songs pauses & restart with cracking sound every few minutes

How did you update it? Update is not showing for me.

Hi, where is the firmware update? for OTA no apear.


Mine updated automatically. No issues.

It shows on 4STREAM App

Hi Joy, update is not showing on my device. I tried restoring factory settings, reinstalling 4stream without success. Can you help?

Hi @Smo Please try to restore to the factory settings.
If it still failed, please send feedback in our 4STREAM APP after the issue happened.

App settings>send us feedback> and let us know the case ID. This will help us check the log.
Thanks for your help!

Hi @meic and @juanantofb ,
Please make sure your model is S50 Pro+. If yes try to visit to check if your network binds our OTA site or not.

If you can browse, and still can’t update. Please send your device info by the steps below to us:

Please input this URL to your browser to help us get some device info:
Replace with your device IP.
You can find device IP in device settings>speaker info>device IP

Then copy all the data you see in the browser to us.
And please let me know your location also(country+ city).

You can send the info to
Thanks for your help!

A few followup questions…

  1. Where can users adjust the default volume step up?
  2. I don’t see preset EQs anywhere…where are they located/created?

Updated the firmware today, throught the 4 STREAM APP and now the S50 Pro + is stuck on the loading screen. Tried the reset button without any success. Any suggestions to fix the problem.

@Den Hi,
Please try to plug off the power and plug in the power again.

Same here

Sure, shall reset & update you

Hi @Callmesb , you may receive another update today.

  1. This can be set by API
  2. This is available for the Web player.

I updated today and the device is not turning on at all. The red light not lights up, the reset button not helping, removing the power not helping … There is power from the adapter as i measured 12V with multimeter on the plug. It looks like is totally dead after this update. Is there a way to update with cable or anything else that can be done?

1 Like

Update: I found male to male usb cable and was able to connect my PC and the device. When connected to the computer the device lights up and works normally, when is not connected to the computer is not working. My guess is that i need to reinstall the firmware from file. I found at the IP address that there is a web interface from where such update can be done, but don’t know from where i can find stable firmware to upload.

So if anyone have a stable firmware version for share will be gratefull.

Also this is the json from the YOUR_IP_HERE/httpapi.asp?command=getStatusEx%201
{ "uuid": "FF31F09E4F9791CE05BBF605", "DeviceName": "Home Audio Streaming", "GroupName": "Home Audio Streaming", "ssid": "Vintage Stereo_E71D", "language": "en_us", "firmware": "4.6.415145", "hardware": "A31", "build": "release", "project": "ARYLIC_S50", "priv_prj": "ARYLIC_S50", "project_build_name": "a31rakoit", "Release": "20220427", "temp_uuid": "6C036BAEFD4BEFBE", "hideSSID": "0", "SSIDStrategy": "0", "branch": "A31_stable_4.6", "group": "0", "wmrm_version": "4.2", "internet": "1", "MAC": "00:22:6C:2E:E7:1D", "STA_MAC": "00:22:6C:2E:E7:1F", "CountryCode": "CN", "CountryRegion": "1", "netstat": "2", "essid": "59657474656C20486F6D65204E6574776F726B", "apcli0": "", "eth2": "", "ra0": "", "eth_dhcp": "1", "VersionUpdate": "0", "NewVer": "0", "set_dns_enable": "1", "mcu_ver": "34", "mcu_ver_new": "0", "dsp_ver": "0", "dsp_ver_new": "0", "date": "2022:04:30", "time": "11:05:56", "tz": "2.0000", "dst_enable": "1", "region": "unknown", "prompt_status": "1", "iot_ver": "1.0.0", "upnp_version": "1005", "cap1": "0x305200", "capability": "0x28e90380", "languages": "0x6", "streams_all": "0x7bff7ffe", "streams": "0x7b9831fe", "external": "0x0", "plm_support": "0x16", "preset_key": "10", "spotify_active": "0", "lbc_support": "0", "privacy_mode": "0", "WifiChannel": "5", "RSSI": "-39", "BSSID": "C8:EA:F8:68:E1:56", "battery": "0", "battery_percent": "0", "securemode": "1", "auth": "WPAPSKWPA2PSK", "encry": "AES", "upnp_uuid": "uuid:FF31F09E-4F97-91CE-05BB-F605FF31F09E", "uart_pass_port": "8899", "communication_port": "8819", "web_firmware_update_hide": "0", "ignore_talkstart": "0", "web_login_result": "-1", "silenceOTATime": "", "ignore_silenceOTATime": "1", "new_tunein_preset_and_alarm": "1", "iheartradio_new": "1", "new_iheart_podcast": "1", "tidal_version": "2.0", "service_version": "1.0", "ETH_MAC": "00:00:00:00:00:00", "security": "https\/2.0", "security_version": "2.0" }

Same here! I’m fn pissed!

I’m sure this can be fixed, but we need to wait someone to send stable firmware file. Definetelly is not very pleasant experience, but at least there is still hope, as initially i thought the device is dead for good.
I feel this is related somehow with power management , as when connected with the adapter the device is not working at all. When power comes from usb it turns on, that’s why boots up when hooked to the pc, but it turns out it works and with external power bank only without power adapter at all. When conencted only to the adapter is not working. So as temporary solution i hooked the USB cable to phone charger instead the power bank and the device is working, but the sound is distorted and not usable, but can be updated at least, when fix comes out.