New General Firmware Upgrade 4.6.415145 - A30, A50, S50, Up2stream Amp Sub April 30.2022

This article summarizes the changes for specific Models A30, A50, S50, and Up2stream Amp Sub firmware release on April 30.2022. And S50 Pro+ also release some new updates on April 30.2022. You can refer to
Firmware Upgrade 4.6.415145.34 - S50 Pro+ April 28.2022

Newest Firmware Version

  1. A30/ 4.6.415145.24
  2. A50/4.6.415145.7
  3. S50/4.6.415145.5
  4. Up2stream Amp Sub/ 4.6.415145.31

New Updates:

  1. Support gapless playback
  2. http API for playing notification
httpapi.asp?command=playPromptUrl:[URL]
  1. Fixed, http API reboot not working

Web Player New Features:

  1. Personal Radio
  2. Audio Settings
  3. Need password for the whole page
  4. Set title for page
  5. Some improvements in Personal Radio and Audio Settings
2 Likes

I just checked my s50 after update and the web player does not work now, “loading…”-text appears, the waiting circle just rotating, but any buttons and menus are unavailable (there are only inactive). the web player did works before the firmware upgrade…

There is the same situation with my old Up2StreamAmp…

Clear your browsing data. Cache, cookies, history, etc …and you will be ok! :kissing_heart:
One more thing, reset to factory settings and setup device again…

Thanks @Pepelitsa, but unfortunately this does not solve the problem.


I was wrong, I still solved it, thank you!

Hello dear Joy thank you for all your efforts, nice job ,
Totally nice new features , there are some bugs:
Input source section doesn’t show USB flash memory to choose.
And also i have a suggestion to add ability to group and Ungroup several zones together in each webserver zones ( MaltiRoom ) , you can add a tab on web server that user can select and input other zone IP ADDRESS to group with . And also one other tab to Ungroup them from each other, as you know we have command via HTTP API to group master and slave zones based on IP ADDRESS , so it could be easily added to web server GUI , user just need to know slave or slaves zones IP ADDRESS to group with main zone

Thank you Joy!
By the way hey there! I just updated all that needed it and seems to have smooth for once… :laughing:!
I’m going to try to be more active in the forums by the way. Got so a huge projects that I’m finishing up plus progress on the JBL Ranger Tremor 2.0 car audio build. Plus the new test bench and facility will be up and going next week with six new sets of speakers being sent to me to test out and make videos for 'Car Audio from the COUCH!!!"
I’m looking forward to getting to know everyone and sharing what information I have with all of you!

Hi, if the loading did not disappear, please try to reset factory for device on app. It’s needed to start a daemon.
And for the web page, if you’re using chrome, please press Carl+R to reload the page by force.

@zpl1025 indeed, it works! I remembered that I had already tried the factory reset, but according to them, the webplayers are working now! Thanks!


@zpl1025 One more question: is there a similar webplayer update for Up2Stream Pro3 and A50 +?

what’s the webplayer password? how to set it up??
(have an s50 pro+)

default password is admin

yes, still working on it.

1 Like