New 4stream App and Firmware Upgrade 4.6.328252

Yes, if i paste this link (and change the ip-address to my local device’s address), then the stream program changes to the new stream correctly (or started from the stopped position correctly) (but i cannot set this stream link either into any program)…

@zitev you won’t be able to see anything in the player we are just testing that your hardware and internet connection is good. Now can you send me an example of one of your m3u playlists and I will test tomorrow. Kevin

@zpl1025 should the latest firmware work with Android Version 8 ?

Thank you, but there is no problem with the content of the playlist itself, since I can play it - the problem is there that I can’t store the stream link opened from my own playlist on the number buttons on the remote control.

OK How do you access the playlists in the 4STREAM app ? e.g. MY Music >> My Playlists ?

No, My Music-> Home Music Share

I can only open the playlist through the Home Music Share, because i can only browse the real audio files through the Phone and I can’t manually add my own stream link to My Playlists.

I have issues with the volume control and stability on Up2Stream Mini v3, with this firmware version.

Please have a look at this Thread: Errors in volume control on Up2Stream Mini v3 ?

I have just added an extensive description of my testing.

4stream app for me was better before when you can slide left or right with a finger in the menu,just my opinion…


I have up2stream mini v2 and after this update the device is quieter and the bass level is much lower now. BASS is set to 5 in 4stream app.

Device is connected trough analog output to Yamaha amplifier.

How to get back to previous firmware or change bass setting as they were in previous firmware?

This firmware upgrade for the miniv2 will only affect the WiFi part which handles the playback and it will not affect the sound. it must be some other reason.

Thank you for the new features!

  • Up2stream Amp 2.1 working well as replacement for Cambridge Soundworks Basscube 12s amp.
  • ACP Workbench is really good at tuning to get excellent sound
  • HTTP API is great- created web interface to change input, sound and preset audio sources

The ability to change EQ settings that have been preset in ACP Workbench sounds fabulous. I unfortunately did not order the remote control.

Can the EQ presets referenced above be changed through the HTTP API ?

Thanks for a great product and support.

Just got an update on my A50 and I’m sure the input gain has been lowered? I’m taking my PC out into it and it seems I need to crank the volume to past half way to get the same as it was previously about a quarter. Eg 20 was loud now I’m at 46. Is it just me?

I’m with v3 amp and from beginning the low volume was to loud,not just with Arylic,every Linkplay device has this problem,no linear volume control,at night the firs step is loud with sensitive speakers, always bugging me for adjusting the volume with my finger at first step…

I recently switched from my Google Pixel 4 to an iPhone 13 mini (iOS 15.0.2). The 4stream app worked great on Android, but I still can’t get it running on my iPhone. The app crashes after a few seconds, except for when I’m not on wifi (but that’s pointless, of course :)). I’ve tried reinstalling the app several times and using it on a different wifi network, but that didn’t help unfortunately.

Is there any way you could fix this?

You can find a video of the issue here:


Yes, mine too
This seems to be normal

Works on my junk drawer iPhone 6 with iOS 12.4. The app host iPhone and Arylic device must be on same network obviously. What’s firmware in devices? I got “new” S10 and it’s factory firmware was not compatible with latest Apple store app, these work for me 4stream version 2.8.9905 and S10’s 4.6.328252.27. Without working app you’ll have to prompt device with status command ie
replace with your device,
reply "{ “uuid”: “FF31F09EFFA0D11A046DFCAC”, “DeviceName”: “Media Room_5101”, “GroupName”: “Media Room_5101”, “ssid”: “Media Room_5101”, “language”: “en_us”, “firmware”: “4.6.328252”, …

thanks for replying so quickly! you can find the firmware version of my a50+ below, but i should note that the app still crashes even when my a50+ is turned off and not connected. it doesn’t get to the „searching for your sound system“ screen, it just shows the 4stream logo and closes after a few seconds. this behavior is not present when my iphone is not connected to wifi. i know that’s pointless and stupid because the devices have to be on the same network, but i figured it might help finding out why it doesn’t work :slight_smile:

{ "uuid": "FF31F09EF05CF56EB2AFC86A", "DeviceName": "simons raum", "GroupName": "simons raum", "ssid": "simons raum_9075", "language": "en_us", "firmware": "4.6.328252", "hardware": "A31", "build": "release", "project": "ARYLIC_A50S", "priv_prj": "ARYLIC_A50S", "project_build_name": "a31rakoit", "Release": "20210903", "temp_uuid": "14D47F0F9F7BC5F6", "hideSSID": "1", "SSIDStrategy": "2", "branch": "A31_stable_4.6", "group": "0", "wmrm_version": "4.2", "internet": "1", "MAC": "00:22:6C:38:90:75", "STA_MAC": "00:22:6C:38:90:77", "CountryCode": "CN", "CountryRegion": "1", "netstat": "2", "essid": "53696D73656C343536", "apcli0": "", "eth2": "", "ra0": "", "eth_dhcp": "1", "VersionUpdate": "1", "NewVer": "4.6.328252", "mcu_ver": "28", "mcu_ver_new": "30", "dsp_ver": "", "dsp_ver_new": "0", "date": "2021:10:30", "time": "09:31:43", "tz": "1.0000", "dst_enable": "1", "region": "unknown", "prompt_status": "1", "iot_ver": "1.0.0", "upnp_version": "1005", "cap1": "0x305200", "capability": "0x28e90b80", "languages": "0x6", "streams_all": "0x7bff7ffe", "streams": "0x7b9831fe", "external": "0x0", "plm_support": "0x8016", "preset_key": "10", "spotify_active": "0", "lbc_support": "0", "privacy_mode": "0", "WifiChannel": "6", "RSSI": "-65", "BSSID": "3C:A6:2F:D2:94:7A", "battery": "0", "battery_percent": "0", "securemode": "1", "auth": "WPAPSKWPA2PSK", "encry": "AES", "upnp_uuid": "uuid:FF31F09E-F05C-F56E-B2AF-C86AFF31F09E", "uart_pass_port": "8899", "communication_port": "8819", "web_firmware_update_hide": "0", "ignore_talkstart": "0", "web_login_result": "-1", "silenceOTATime": "", "ignore_silenceOTATime": "1", "new_tunein_preset_and_alarm": "1", "iheartradio_new": "1", "new_iheart_podcast": "1", "tidal_version": "2.0", "service_version": "1.0", "security": "https\/2.0", "security_version": "2.0" }

oh, and some information about my iphone:
iPhone 13 mini (model number MLK33ZD/A)
iOS 15.0.2
4stream app version 2.8.9905

1 Like

A tip for those who, like me, have problems with the structure and speed of the new 4Stream app: the android “iEast Play” and “AudioCast” apps provide the same module communication, but still on the old interface - true, the new interface specific feature (EQ ) is not available with these - but this is not used to track it on the streamer, for example (it is advisable to use a linear, colorless output for the amplifier)…

1 Like

thanks, tried it and my a50+ works with the ieast play app!