Errors in volume control on Up2Stream Mini v3 ?

I have some errors on volume control with my Up2Stream Mini’s v3.

My setup
2 active speakers (built-in amplifiers) with Up2Stream Mini v3 (FW 4.6.328252.28). Configured as a stereo-set in 4Stream App.

This is what happens
If I start playing music and the volume setting for both speakers is even/at the same level, everything is fine. But only as long as I don’t change the volume.
If I do change the volume, I only use the ‘Group volume’ slider to handle both speakers evenly and at the same time.
But what happens is that one slider follows exactly what I do, and the other slider doesn’t. For instance, If I put the ‘Group volume’ slider to zero, one speaker also goes to zero, but the other stops at 10% volume, so stays on.

What I tried

  • I tried to restart the WiFi network, and also restart the Up2Stream Mini’s. Didn’t work.
  • I also tried to reset the Up2Stream Mini’s (Restore factory settings). Didn’t work.

Suspecting …
I never had this before, it started after the update to firmware 4.6.328252.28.
Also I noticed since the new firmware that the WiFi signal strength can be very low (below 70% or even far below that, where I am used in this environment to have between 89% and 100%).

Question
Anyone who has an idea what is going on?

Picture: example of mismatch in volume control.

Ernst,

I think there is an issue with the multiroom volume control too. I haven’t had time to look at it in any detail yet but the biggest problem for me is

  • Playing Music Single Room Mode - nice volume
  • Add a Device the the Multiroom Group
  • Master Volume jumps to shockingly loud, Slave Volume OK

When I get time I will make a proper test a report findings :slight_smile:

1 Like

@NWT.Stuff
This sounds to me like the same issue.
When I have time, I will do some more checking. Also interested in your findings.

In the meantime I have done some testing. The results are worse than I expected.
Here’s my description and results.

Test case set up

  • 2 active HiFi speakers, each with a Up2Stream Mini v3, with FW 4.6.328252.28, 20210903.
  • Used in testing: iPhone 11, iOS v 15.0.1, 4Stream App v 2.8.9905.
  • WiFi strength on both speakers: both 100%

Schermafbeelding 2021-10-02 om 13.07.13

Problem 1 description

While playing music, without changing volume, this happens:

  • One of the speakers can suddenly stop playing music, just for a split second. And then start playing again.
  • If this hick-up happens, there’s also a clear latency between the two speakers. This solves in 1 – 3 seconds.
  • The hick-up sometimes happens on the left speaker, and then suddenly on the right speaker. In just 5 minutes the hick-up can happen 6 or 7 times on the left or right speaker.

Problem 2 description

When changing volume, the volume does NOT change equally on both channels (L + R).

Case 1: volume UP testing– Starting with the volume set to 0, the volume is increased in single volume steps, by pushing the volume up button on the iPhone. The following screenshot sequence shows what happens with each step. If you look closely, you can see that the volume on left and right channel move uneven.


What happens with volume UP

  • 1st test – From 0 to 1; only the right speaker responds, the left speaker stays at 0 / off. When increasing the volume from 1 to 2; the right speaker goes up one level, the left speaker jumps from 0 to 2. It seems that at every uneven volume up step, only one channel responds. And at every even volume up step, one channel moves 1 step and the other moves 2 steps.
  • 2nd test – Doing exactly the same (moving up the volume step-by-step), I noticed following. From 0 to 1 only one speaker goes on (like before). After moving to level 2, the other speaker also switches on, but the volume difference remains 1 step between the two speakers. Even after increasing the volume 7 steps.
  • 3rd test – Doing exactly the same again, so starting at volume 0. The 4Stream App does not respond at all to increasing of the volume by pushing the iPhone volume buttons.
  • 4th test - When using the 4Stream App for volume control, and increasing volume by using the ‘Group volume’ slider, left & right speaker move equal and in the right steps.

Case 2: volume DOWN testing– Starting with the volume set to 6, the volume is decreased in single volume steps, by pushing the volume down button on the iPhone. The following screenshots sequence shows what happens with each step.

What happens with volume DOWN

  • 1st test – From 6 to 0; at the starting point, the volume levels at left and right speaker are even. From the first step for volume down onwards, one speaker stays a level behind. This goes one coming to level 0. But the speaker that was one level behind is unable to reach level 0. So, the volume stays on with one speaker. It is not possible to get it to 0 / off.
  • 2nd test – More or less the same happens, but sometimes the difference between the left and right speaker, is 2 levels.
  • 3rd test - When using the 4Stream App for volume control, and decreasing volume by using the ‘Group volume’ slider, left & right speaker move equal and in the right steps.

My observation

  • Besides controlling the volume by pushing the physical volume buttons on the iPhone, I also used the volume slider in the Spotify App. When moving the Spotify volume slider, and then looking at what happens with the volume controls in the 4Stream App, I could see the same problem happens. So controlling the volume by iPhone volume buttons or Spotify volume slider, makes no difference.
  • Controlling volume with the ‘Group volume’ slider in the 4Stream App works correct.
  • I have this issue now on 3 of my speaker projects. All 3 are stereo sets, so two speakers (with Up2Stream Mini v3) combined to a group as a stereo set. Each speaker pair is in a different house on a different WiFi network.
  • All three sets behave the same as described above.
  • All three sets functioned well for several months, until the firmware changed to v 4.6.328252.28.
  • What I also experience with the latest FW, is that sometimes when I switch off power, and then switch it on again, the Up2Stream Mini boots up in setup mode, instead of just restarting and remembering all settings.

My question

  • Who is experiencing the same?
  • @rakoit @arylic: this looks like a bug, can you please comment?

You did very detailed testing :+1:
For adjusting group volume on app, can you hear the difference between devices? Because I suspect the app display is not refreshed on time.
For Spotify, I have the volume problem either, and still in debugging for a solution.

1 Like

Thanks @ZPL1025. Yes, I can hear the difference. I am 100% sure it is not the screen refresh.
You can hear the difference on the speakers (the same way it is shown by the screen in the 4Stream App).
Anyhow, what also happens is that there are sometimes hick-ups in the volume. See my descriptions in the 3 bullets at “Problem 1 description”.

To me this looks like a software bug.
Any ideas?

@zpl1025 Frank, I am not sure if this is related but when in multiroom zone both Master & Guest Device when I use httpapi command

http://192.168.167.75/httpapi.asp?command=setPlayerCmd:vol:

The Volume on the app slider changes and the command

http://192.168.167.75/httpapi.asp?command=getPlayerStatus

Also shows that the Volume level has changed. However on the physical output the volume is not changing for either Master or Guest/Slave.

FYI using TCP/IP command

MCU+PAS+RAKOIT:VOL:NNN&

Works as expected. slider and physical volume changes.

@NWT.Stuff - Thanks Kevin, for following this topic and sharing your input!
Interesting that the way you tested, you see normal behaviour of volume sliders and hearable volume.

I have chosen to test it like a user uses this stereo set. That’s why I look at the behaviour of the sliders when operated by the volume buttons on the iPhone and the volume slider in Spotify.

As said, I have three stereo-sets with three different people, in which I have the same configuration (Up2Stream Mini v3, FW 4.6.328252.28).
In all cases, including my own test system) I have the same problems with volume control.

@zpl1025 & @NWT.Stuff hope you have further ideas or suggestions.

One of my ideas is to downgrade the firmware to one version back. This one functioned without this problem. Do you know where I can find that firmware?

Update
I have just tested with the latest App version of 4Stream (2.8.9905), and older FW (4.2.9326.26).

If I try to group two speakers together, one with FW 4.2.9326.26 and one with FW 4.6.328252.28: this is not possible. I get a notification like ‘this version has expired, please update’.

@zpl1025 - Dear Frank, can you please comment?

  • Is this just an error because two Mini’s can’t be combined in Multi-Room because they have to have the same FW to do that?
  • Or is older FW than 4.2.9326.26, not supported anymore by the last version of 4Stream?

These 2 version firmware are both supported, but the devices need to have same version to group together.

For the volume issue, I’ll look into this when I get back to office tomorrow.

1 Like

@zpl1025 - Thanks Frank!
Firmware versions

  • I understand that 2 different firmware versions won’t group, clear.
  • I don’t know how to downgrade firmware, as the module seems to automatically upgrade firmware by itself. Please advise?

Volume control issue
Yes please, have a check. I have three stereo sets (6x Up2Stream Mini), in different locations/houses. They all have the same issues as described.

I hope you have a solution.