Just updated my UP2Stream HD today and it is now dead!!!!!

Hi Martin,

We’ve pushed version 45 to OTA, and it should fix the power up issue with less current power adaptor. Did you ever upgrade and any issue?

Many thanks for the info Frank.
I think I will wait until my second board arrives and will then update it.
Be good to try it.

Hi Frank,
As if by magic the replacement board arrived this morning. I checked it and, as requested, it is already updated and running the latest which is .45. Many thanks.
I then took the plunge and updated my other board and it is now running .45 as well.
Many thanks and it looks as if your boot process update is working well.

I have some Problems with my Up2Stream HD after updating to firmware 4.6.437434.43.
From time to time (randomly) the music is not playing accurat. It sounds a bit like a skipping CD player, when a scratched CD is playing. This appears when playing Spotify and also when playing flac-files from my NAS.
The board ist connected to my network by ethernet-cable. I use a linear 5V/3A power supply.
My network is working fine and i don’t have problems playing music with other devices like Denon AVR , PC and Up2Stream Amp 2.1.
So it seems to be a problem with my HD board. A couple of days ago it offers a new firmware 4.6.509530.45. I updated the board but the problem still exist.
I contacted Arylic one month ago. But i haven’t heard anything since then.
Listening to music with this problem is no fun. So actualy I have a 250$ piece of electronic waste. :frowning_face:


Hi NoSie,
I have bought two boards and both failed completely. Both have now been replaced and are running .45.
One thing I have noticed however is that, just after power on, for a few minutes audio glitches a bit like you describe.
My system is all wired as well.
After it has been on for a few minutes they play OK.
I noted earlier that I initially had to heat the Linkplay module with a hairdryer to get the board to boot.
The latest fix seems to sort out the boot issue but I suspect that there is still an inherent temp issue with the Linkplay module. Once it has been powered for a while it plays OK. Maybe you could check this behaviour. The Linkplay module on the HD is different from that used on the 2.1 Amp.
Frank has been very helpful so I hope you get some comms soon.

Hi Martin, it’s great to know it’s working well. Thanks for your patience.

And regarding issues happened in NoSie’s building, I’m not sure what’s going on, but could help to record a voice clip to make it clear.

Hi Martin,
thank you for this info. I will check if there are more glitches after power on. But I don’t think that is the problem with my board. There are also glitches longer time after power on.

Hi Frank,

i will try to get a record of the “skipping” sound. And I try to write down when and under what conditions the problems occur.

Hi Frank,

I have two mp3-files of the skipping sound:

These are approximate positions where it can be heard:

File 2:


The effect occurs randomly. Sometimes after powering up, sometimes after playing two or more hours. On some days there are only a few, on others more.
It can be heard using the analog output and using the S/PDIF output with an external DAC.
Sometimes it occurs only once, sometimes frequently.
Until I updated the board to firmware .43 it played fine.
The problem also exists with the firmware .45.


Hi NoSie,
I have checked mine in a bit more detail. As far as I can tell it is a temp related issue. It skips often within 20 mins of being switched on. After that it streams music OK. I use the optical out to an external DAC.

With Optical in with the extension board, TV audio mutes for around half a second every now and again. It also mutes when the app is interacted with (adjusting volume etc).
It is still possible that it is a temp issue for you but the range/tolerance is different.
Given that the Linkplay module seems to be responsible for this I would be chasing them for answers.
Any input here Frank?

Hi NoSie,
I noticed the audio gap in playback… that’s really bad experience, especially for music lovers. I believe you purchased for HDDAC for better audio performance. I’m really sorry about this issue, and will chase to solve it.
And regarding the issue, what source you’re playing? online music service? and could you try to check with a song on your phone memory?

Hi Frank,

there is no difference between playing music from my Synology-NAS (flac-files) and Spotify connect. I usualy dn’t play music from my mobile phone, but I can check this.

Hi Frank,
Any progress with the skipping issue. The two boards I have both do it and it is extremely annoying.
I also have audio drop out of around 0.5s every few mins when using optical in with the extension board. It would be great to have these issues fixed as it is almost impossible to listen to good music the way it is now.
Note; I am still sure it is a temp related issue. If I leave the board powered up it eventually works OK.

Hi Martin, Sorry for the new issue. We’ve reported to Linkplay and waiting for a version firmware. Maybe could expect for it in mid of May.

Thank you Frank. As I have mentioned on many occasions, it would be great if the software log were kept up to date. When will this be done?

Hi Frank,
thank you for the information. I did some testing to find out under which conditions the gap/skipping problem appears.
I tried:

  • two different power-supplies: a standard USB power supply and a special ultra linear power supply for audio devices
  • analog output, optical and coax S/PDIF with external DAC
  • the board usualy stands near other hifi-devices, I tried to place it with distance to other devices
  • playback music from Spotify, my NAS (.flac), my laptop using foobar2000 and smartphone using the 4stream app

Under all operating conditions the gap/skipping can be heard. I’ve had days without any problems and days where it was impossible to hear music.
May be these information can help to solve the problem.


Thanks for the effort, NoSie, I will keep following this issue.

Hi Frank,

are there any news about a new and working firmware?

Hi NoSie,
I have heard that an update may be on the way.

we still don’t have a perfect solution. We still could get the glitches with the latest version, but a lot better, not happening so frequent. I think engineer should have understood the cause and try to fix.