Just updated my UP2Stream HD today and it is now dead!!!!!

Hi I just updated my UP2Stream Hd and it is now dead. It went through the update process with the correct audio prompts but then powered off and will not restart.
I have checked the PSU (4.97V) and it is OK. I also powered a separate Optical converter board from the Arylic and it is receiving no power. The output 5V output socket shows no power. Looks like the main board dead now.
The rest of my products and system are working fine.
This update (Can’t see the number now!) seems to have killed my product.
What now?

Just tried the “factory reset” using the mode button…still dead.

I just updated mine to new version (0.43) and it went well i.e no bricking.

No Amazon HD yet but trying both optical and coax output some glitching on Amazon music, not apparent on BBC radio, Spotify playing ok too.
Still can’t get Airplay to work between my iPhone and Up2Stream.

Errr, that’s not expected. If the LED is not blinking when powered on, it might be dead, consider to send it back to repair.

Agreed! I have checked and changed the power supply…The arylic is dead.
The full update was this;
It ran through the update and then for some reason connected to WiFi, even although it was wired Ethernet. I powered it off and on again and it was dead.
Any ideas how you get a return for repair initiated?

Hi Martin,
Just wondering if the update was completed when you powered down?

Hi Steve,
Yes, it had. The audio feedback stated it was completed and the unit appeared on the app. The only reason I powered it off was because it stated that the connection was by WiFi and I generally wire units.
After this re-power, it is now dead.

While I don’t use the same units, I always think it’s odd that on boot up they say with a voice “connected to WiFi” when in fact they are obviously connected via ethernet cable. Probably a translation thing.

Anyways, I’m sure this wasn’t what happened in your case.

Same here DEAD! Arylic Up2Stream HD DAC after firmware update 4.6.437434.43 updated yesterday today its dead!

Power supply is in perfect condition.

Yesterday morning I performed a firmware update on my DAC. Yesterday I was able to listen to music almost all day long. What stood out is that every now and then I could hear a small tick. Strange I thought. Today I wanted to turn on my dac but unfortunately everything remained dark (I have a display).

DEFECT I’m afraid.

Hopefully Arylic can take the DAC back and fix it.

Hi there,
I am not alone! Well, Arylic should pull the update until the problem is identified and fixed.
This is the first issue I have had so far, normally everything goes very well.
I have requested a return. Check the warranty page at the foot of the “Store” page a.wie.
Will update how I get on.


Hi there,
Here is a thought (may help Arylic)
Can you confirm it worked after update but bricked when powered off and back on again?
Given that I powered it off right away to get it to connected to wired ethernet then this may match what you did.
Does this fit with what you did?
Many thanks again.

I did the update and then had to leave for an appointment. My dac has been on all day and turned it off late last night. At the end of the afternoon I wanted to turn on my DAC but it did nothing.
In fact, even after turning it off, it didn’t turn on anymore.


Hi Arjen,
Well that pretty much matches what I did.
Over to Arylic and many thanks for your help here.

Hi Martin,
I managed to get my DAC back on. I’m not sure how. There is also a button board on my DAC, I pressed a button and suddenly the DAC started. I also pressed before this the reset button several times. Shortly did I see a minimal current increase on my USB voltage and current tool??

Hopefully this can help you too. And hopefully it keep on working.

I have tried the reset button and got nothing Arjen.
Where have you found this other Button?
Permission to say Yea Ha if it works.

I have the board from Arylic it’s an option. when I got it to work I had connected it to a windows Laptop.

Hi Martin
Same thing this morning DAC would not start.
Only after a view minutes of trying it started.
Left it on today

Hmmmm. I have tried a few times but no luck.
Arylic has now said it will replace my unit. Just waiting on an update as to how this is done.
Thanks again for the feedback.


Hello people,
take a look here, read through the thread: DeJaVu.

We had the same problem with the S50Pro+, maybe you get it back to life by using another power supply…

Hi Hulle,

Many thanks for the additional input.
I have now tried another power supply and also tried to power it on with IR.
No luck either way I am afraid.
Will update when I learn more.