Firmware Upgrade 4.6.415145.35 - Up2stream Pro V3, Up2stream Amp V4 June. 11. 2022

The update detail is related to Up2stream Pro V3, Up2stream Amp V3, Up2stream Amp V4

  1. Add preset EQ, Flat/Classic/Pop/Rock/Jazz/Vocal
  2. Support gapless playback
  3. HTTP API for playing notification
httpapi.asp?command=playPromptUrl:[URL]
  1. Fixed, http API reboot not working
  2. Adjusted default volume step to 5
  3. Adjusted minimum MXV to 30
  4. Add extra IR code for power on and power off
  5. Will reboot device and enter WIFI mode when sleep timer out, to avoid system not response in standby.
  6. Add -BLE appendix for BLE device name to distinguish with classic bluetooth
  7. Sync VB settings when set in ACPWorkbench
  8. Fixed, can’t switch to LINE-IN mode on boot
  9. Fixed, connected BT device is not forgotten when factory reset
  10. Fixed, used treble value for bass on boot
  11. Fixed, system detected silence when input level is low

Web Player New Features:

  1. Personal Radio
  2. Audio Settings
  3. Need password for the whole page
  4. Set title for page

Hi Joy,

Many persons seems to have a problem with this last firmware.
Especially with the sound volume : when start the amp the volume is on defaut volume but when trying to change it, the sound become imediately at maximum or at zero.
The only way to solve this is to make a factory reset from the app, but the issu still coming back every day.

R.B.

Hello Joy,

After the Update, I have to do a factoryreset to be able to listen via Bluetooth.

After the next powercircle, I can connect to the device but no music is playing. Only after a factory reset, I can connect AND listen to music - until I switch the device off and on again.

Furthermore the web interface is not working and therefore it is impossible to connect to my own wifi. So basically with the update, the thing is bricked and not usable.

Is there a fix for this or a possibility to downgrade to the last firmware? The last one worked like a charm. I’m using the amp V4

Cheers Simon

1 Like

Hey @Joy,

Will there be a possible downgrade? Like I said before, the device is now literally a brick.

Cheers Simon

1 Like

Hi Simon, could you please help to try this version? And see if the problem fixed.

Hey,
this beta fixed basically all my issues. Thank you. Do I have to set the OTA mirror back to the default somehow?

Cheers

Hello,
I have no idea why there is a firmware upgrade because every time there is my device becomes a brick. I just thought I was purchasing a device that would work. If it works then stop trying to fix it.
This is the third time it stopped working for me. First time I found a step by step solution. Second time, after a few days it started working. Now, I have know idea what I’m supposed to do even with what you told SimonA to do???
Very frustrated with this device and company.

Hi, I suppose you’re also suffering for the volume issue. I’m really sorry for all the mess, and have pushed the new udpates for AMPV4, and will update others soon later.
Regarding the upgrading. We keep working on upgrading firmware to fix issues and new features, maybe they’re not desired for everyone, but we’re trying to make it better. And because we’re working on a some what open board to let user customizing with many configs, and that makes the system a bit complicated for fully testing.
And, don’t feel frustrated, enjoy the pain and joy of DIY :slight_smile:

1 Like

Well…I tried to reset the device to factory settings and that didn’t help. So is there any way for me to fix this with instructions or am I supposed to wait for another update?

I suspect the cause of the volume issue and maybe some other strange behaviour is that memory overflow while composing a reply message for EQ groups. Did you ever save different EQ groups with ACP tool? If so, could try reset factory on ACP tool and check. I’ve expanded this tmp buffer in firmware and also will check bundary to avoid problem.

This is my issue after update. How to fix it?
Firmawe: 4.6.415145.36

I have the same problem, with the volume.
Did you try to press the reset button tree times?

@dulmateusz I had same issue. Factory reset helped me. But it was not a simple thing. I didn’t have access to the device settings in the 4stream app. So the solution was to right click on loading screen in browser, select Inspect and delete div with class “loading_mask”. Then I had acces to settings menu and could perform factory reset. After that everthing is as it should be.

1 Like

Should sort itself after you do a factory reset

Please, reduce default volume step to 3, because 5 is to much, now I cann’t normally adjust volume with remote control, it’s too loud or too silent with step +/-5.

My observations with S50 Pro+ a volume stepSize is different between: spotifyApp=3, 4streamApp=7, one click on the volume button of my Samsung, remoteControl=5 one click on the volume+ button.

Request to Arylic for the next sw patch, to make the size of one volume step fixed independant from where you control the volume, and the step size easy configurable for non-technical users. I prefer stepSize of 1, I rather click several times to get the right volume level than go too soft or too loud and have to use the volume slider.

yousername

10d

Hello,

Thanks for a great product, I have a suggestion which regards to the online radio in the webplayer, I have added a station to my private list, and liked the fact that one can assign besides location and language also an image. unfortunately there is nothing foreseen to display “now playing” meta-data, I hardly know anything about coding, But I know that it is possible, for example VLC can somehow encode title and artist info.

A solution could be to allow the image field to contain a webpage, or use an existing embed player.

the radiochannel I’m playing for example has its player here: Radio 1 Classics - Radioplayer
the AAC track is here: http://icecast.vrtcdn.be/radio1_classics.aac
“Now playing” info is then fed through this IFRAME: VRT Radioplayer Frame

Another issue I would like to report, One of the U2s PRO V3 devices I have nearly always goes into setup mode after a power cycle. Only one device is behaving like this, I also have a U2s Mini and another U2SProV3 who are not showing this faulty behavior.

Apologies if this was asked already, I am just lazy and did not read the entire above discussion, it seems I have posted this in the wrong section
Thanks

Hi, I recently purchased an AMP v4. I connected it via ethernet cable, and powered it up. Opened up the app, the device was discovered and I was prompted to do a firmware update. I proceeded with the update and eventually the app reported the upgrade had failed and I should reboot. I cycled power to the AMPv4 and it never came back. The app can’t detect it, I see no soundStation wifi network. The led is blinking green about once a second or faster. I’ve left it on for hours, I’ve tried 3 short button clicks. Single clicks do make the led switch modes.

It appears to be totally inaccessible - what can I do to recover this device?

Thanks