Firmware Upgrade 4.6.415145.35 - Up2stream Pro V3, Up2stream Amp V4 June. 11. 2022

you could check if the music link is working within your browser: http://10.10.10.129:8000/Volumes/Media/Music/s.mp3

Thanks for the response. I tested this command with the Postman on mac:
With an IP address and a dedicated port of 8000 of the local source file without “http://” in command:

  1. http://10.10.10.254/httpapi.asp?command=setPlayerCmd:vol:100:play:10.10.10.129:8000/file:///Users/arman/Desktop/Arman/Track24.wav
    With an IP address and a dedicated port of 8000:
  2. http://10.10.10.254/httpapi.asp?command=setPlayerCmd:vol:100:play:http://10.10.10.129:8000/file:///Users/arman/Desktop/Arman/Track24.wav
    or without the IP address:
  3. http://10.10.10.254/httpapi.asp?command=setPlayerCmd:vol:100:play:file:///Users/arman/Desktop/Arman/Track24.wav
    I tried with different ports and also on Windows OS, but it did not playback the sound.
    I can access the wave file in the browser’s address bar with this command:
    file:///Users/arman/Desktop/Arman/Track24.wav
    It is weird since I can change the volume, but the command for changing the left and right channels (ch:1 or 2) or playing the commands above doesn’t work.

You need to test the link is able to be accessed on browser first, to make sure the HTTP server is working normally. The device and the HTTPAPI should be OK. I guess the issue caused by your HTTP server configuration. And also, please note that the URL has a rule for special characters, eg: %20 for space.

And the other 3 links you’re tried are not a common http URL.

I have 2 bricked Pro V3’s now. In both cases, received an update that somehow failed and they never came back.
The “update tool” connects to them over wifi (I haven’t changed my network name nor password and it seems like it still connects to wifi fine, even if the led just flashes rapidly incessantly) sends over the bin file but nothing else ever happens.

The web interface doesn’t move on from asking the admin password, and the app doesn’t even try to install the update, just says there’s a failed update.

ACP Workbench DOES recognize the device, and I could install a firmware update through there, BUT it expects a .mva file that I can’t seem to find anywhere since the firmware update files provided by arylic are .bin

how did you solve this??

I eventually gave up. And it’s only when you do that things seem to work lol. I had every intention at that point to send the units back for a replacement. One magically came back after moving it closer to the router. I do not have an ethernet cable to plug into it and force any more updates, but after moving somewhere else and trying (multiple times) over again, it eventually came back to. The other unit I had given up on I left unattended for several days. I don’t even know why I decided to plug back in, but once again, it magically liked this new location and worked like there was never anything wrong.

We truly live in a simulation :rofl:.