Firmware Upgrade 4.2.9326.26

Bug Fixed:

  1. Fixed, when started the USB playback and then change to WIFI mode with remote, and after 10secs, the device swtich to USB playback unexpectedly.
  2. Fixed, can’t turn off Line-in LED on A50.
  3. Fixed, when plugged with AUX cable, the device is always in line-in mode after power on, regarding the last input mode when power off.
  4. Fixed, When no USB stick is inserted, the Red LED flashes rapidly when switching to USB mode
  5. Fixed, When Up2Stream Pro v3 is connected to PC by micro USB, cannot turn off the device.
  6. Fixed, when exit multiroom mode, switch to line in mode and regroup multiroom, there is no sound output.
  7. Fixed, When power off A50, the LED still have light.
  8. Fixed, when S50Pro+ act as slave device in multiroom mode, press remote controller play button still display previous media info.
  9. Fixed, when in multiroom mode, adjusting the Master EQ settings will cause broken sound on slave device.

New Features

  1. “Power button new settings:
    When device is on:
    Short press once: switch input mode
    Long press once: switch off
    Short press twice: disconnect current WiFi connection and enter paring mode (WiFi mode); Disconnect current connected Bluetooth device (Bluetooth mode)
    Short press three times: restore the factory settings
    When device is off
    Short press: switch on”
    Support to set trigger PIN to turn off amplifier in ACPWorkbench. When set, PIN will be pulled up internally, and will be triggered when short to GND.

  2. “Remote new features:
    Long pressing POWER button: support to reset to factory settings.
    Long pressing WIFI button: Enter WiFi pairing mode(Under Wifi mode)
    Long pressing BT button: Disconnect current device(Under BT mode)”

  3. Add API command to turn off the prompt voice

  4. Add API command to assign the default input mode when power up the device.


  1. Improve line in input detection
  2. Support to turn off OLED screen with display button on IR remote
  3. Add API command to apply minus pregain before BASS/TREB effects.

Download UART


In 4Stream over iPhone, the firmware version displayed for my recently acquired Amp 2.1 is 4.2.8020.13. And there is no button to upgrade (see screenshot). I wonder if this is an old firmware and what to do (?)


@Joy Title of this post isn’t correct. It should be: 4.2.9326.26
That is what my devices show me. :wink:

1 Like

Hi @pogona06 , send a mail to for customer service.
We will guide you how to do with that!

Oops, my mistake :sweat_smile:
All ready modified, thank you :wink:

I have finally found the solution to the non detection of the firmware upgrade: I un-installed 4Stream App from my iPhone, and re-installed it. When it has detected the Amp 2.1 device it has proposed the firmware upgrade and it now runs the 4.2.9326.26.

Hi @pogona06 , thanks for sharing!
This is helpful!

I still have trouble with the volume board added on the Up2stream pro V3, i just installed the latest upgrade and volume only goes up, also with the volume anti clockwise. With previous firmware it worked!

Hi @pogona06 , it is not connected with the APP, the upgrade file for AMP2.1 is not configured correctly before. And I’ve just fixed it today, thanks for your notice :slight_smile:

Hi @riba , will look into this issue, thanks for the feedback.

thanks for checking! the strange thing was that the volume board never worked. Then i bought a new up2streamproV4 and it did work, but asked me to install the latest drivers and the issue was there again.

There is also a little issue with the input name in the 4stream app. When selecting input USB it says ‘CD’. Something i mentioned Arylic earlier when the up2stream Pro V3 was introduced.

This issue is caused by the wrong voltage used on Up2Strem PRO V3… the VCC is supposed to be 3.3V, but it’s actually 3.6V. I’ll adjust in software side.
Btw, I don’t understand that ‘install the latest drivers’, and what issue happened?

the issue: i bought another new V3pro because the first boards i bought before the volume board came out. With the new board the volume board worked fine up and down, but 4stream app asked me to update so i did with version 24 i thought it was. Then i had the same issue again: so volume up and down =volume up. No down.

I have a set of speakers made for a client and she is reporting that after this update, with the new power button settings, the input can be switch with the power button and with the mode button, and this is a little bit messy have two buttons that do the same. Is there any option to change this settings or revert this? Power buton for power and mode button for input switching as it was previously.



Hi Joan,

We’ve add the functions to the only button on board as much function as possible, and it is simple enough for comman usage. I understand it brings inconvinience in your project, I’m sorry for that, but it’s not strong enough to make changes. And it’s complicated to make it configuable.

For new projects, since you’ve extended the mode button with ADC key, you can extend the standby key also. And hide the button on rear board. For the existing project, it might be not good to change the hardware, could you persuade the client to accept? It’s not big problem.

Ok, understand.
Only to clarify, now both buttons (power and mode) do exactly the same, or there are any diference?
I understant that power button now can switch between inputs, but you can power off with the mode button?

no, the MODE button only switch input modes, and the button on rear side of board, has multiple functions like POWER/MODE/RESET_WIFI.

Perfect, thanks.


Does this update apply to Up2Stream Amp V2? I’m not seeing the firmware update available in the app even after pressing on the firmware version.