Cannot Connect to Wifi

Now there is 2 way to do the first WIFI connection setup with Arylic System. One is through connect device AP for connection, the other is BLE connection. All products are support AP connection method, and BLE connection already support most of our new products. If your device is compatible then we advice you use BLE connection method which is more easy and fast.

The model below is not support BLE connection:
A50/S50 PRO/S50 PRO+

BLE Connection

Before using BLE connection, please make sure that you already open your GPS and Bluetooth on your phone. These 2 requirements is for get the IP address of our device. It won’t access any data on your phone, after the first setup you can close them.

  1. After you power up the device and set to the WIFI mode, the LED indicator will display white light and blinking fast. At this moment, the device is rebooting. Please patiently wait 30-60 secs, then device will turn into slow blinking. When the white light blinking slow, it means the device is ready for connection. Now you can start the WIFI paring.

  2. Open the 4stream App then app will pop up the setup instruction. If you already setup with other device then click the “+” on the top right to add other device. Next the setup instruction will ask you if the white light status is blinking or not. Click “indicator is blinking” to the next step. Then there will have devices listed, choose the one that you are going to setup the WIFI connection and click “Setup this device.”

If your device is not display on the list, you can click the power button twice then you will hear hint voice" waiting for WIFI connection."

  1. Now the instruction will list the WIFI in your home, choose the WIFI that you want to configure and click “OK” to next step. Next input your WIFI password and click “Next”

*First WIFI configuration need to use 2.4G WIFI, after first connection, you can use same 5G network for streaming.

  1. To this Step, our system is configuring the WIFI connection. Please wait for 30-60secs. Then, you will see the hint that the WIFI connection is succeed and click “OK”. Afterwards, you can start to use our device.

You can refer to the video below for AP and BLE WIFI connection:
BLE (Start from 2:44):

Failed Connect to WIFI? Solutions below :point_down:

  1. First Check the light status. If the white light blinking fast, this usually because the bad contact between the WIFI module and bottom board. Now you can try to insert the WIFI module again.
  2. Try to power off and on again.
  3. Try to reset the device, press the power button 3 times entering the reset. Wait for 1-2mins, when the white led blinking slow then you can start to pair WIFI again.
  4. Try to connect by Lan cable, after insert the Lan cable the white light will turn into fixed. Now the device is connected, open the 4stream app to restore to the factory settings. The route is: device settings> speaker info>restore to factory settings. Wait for 1-2mins, when the white light blinking slow you can take off the Lan cable and pair the WIFI again.

If the solutions above are failed, the issue must be hardware defected. Once your device still under the 1 year warranty period, you can send the info below to, we will arrnage replacement to you.

-Confirm you already tried all solutions above
-Your order number(If you are not buy from our afficial store, please offer the screenshot of your order. Who buy from the reseller or distributor please apply the replacement from your seller.)
-Shipping info for replacement
-Other details if needed"

Last Updated: Oct. 20.2021

I have tried all these steps but still cannot connect my Up2Stream Pro V3.

I can detect my device from the 4Stream app:


But either it goes back to the connect screen all over again or it times out:

Should encryption be turned off? I turned off my 5 GHz radio in my router so it’s only broadcasting 2.4 GHz. Using the iOS app. I have factory reset my device several times and gone through all the procedures in the manual.

Hardwired trial yet? That cuts through all the encryption, passwords, channels, etc
When you’ve got hardware on subnet scan it to determine hardware ip or look at router table.
Try a ping to it from browser and then run command line “” replacing ip above with your Up2Stream Pro V3’s IP. About 2nd line of response see “firmware”:“4.6.9724” what you got? If Pro V3 not getting on gateway it’s firmware might not work with newer you might have on 4Stream.

1 Like

I’m having the same issues, also IOS. I originally had the A50, couldn’t get it to do anything at all for setup. I just received an A50+ as a replacement. This one gets farther into setup, but won’t connect to my AP (5G channel disabled, only broadcasting 2.4ghz). It’s right above my network switch, but even when I plug directly i to the lan, still doesn’t connect. The only time it connects at all is through the “alternate setup” method switching to the SoundSystem wifi, but then I’m unable to reconfigure it to my AP and it loses connection as soon as my phone connects back to the AP. I’m about fed up with these boxes, can’t seem to perform the most simplest of tasks connecting to my AP that’s on the ceiling right above it.

1 Like

Try to connect your phone to the wifi of the device directly and then go to the app and press the “add” button. After that you should be sent directly to the Network selection and connect almost instantly with an additional voiceprompt “connecting to your wifi network”. I reported this a couple of times in the past, the “normal” way to set the devices up seem to fail a lot in some networks.

One more tip, make sure the VPN on phone is not activated. Or else, the APP won’t discover the connected device.

I recently refurbished a customer’s vintage Yamaha CR-800 receiver and upgraded it by including an Up2stream Mini V3. As part of testing I connected it to my AP, but unfortunately forgot to factory reset the device when he picked it up. Now the customer can’t get it connected to his WiFi AP.

Yesterday we stepped through the Mini V3 / iOS WiFi connection procedure over the phone. As I was doing that I was doing the same at my end on one of my own Mini V3 / iOS to make sure we were doing the right thing. It seems though that there is a particular problem with a Mini V3 that is already registered to an AP that is NOT available, compared to one that is registered to an AP that IS available.

For my Mini V3 that is registered to an AP that IS available these are the steps that repeatably worked:

  1. Power off Mini V3
  2. Hold reset button down
  3. Power up, whilst holding reset button down for 5 seconds
  4. Wait for Soundsystem_xxx to appear in networks list of iOS Wifi Settings
  5. Immediately select Soundsystem_xxx
  6. Use 4Stream app to configure the Mini V3 / factory reset etc etc.

Presumably this is correct?

On the customer’s iOS phone, Mini V3 ‘Soundsystem_xxx’ does briefly appear in his networks list as in step 4, but when he selects it, it will not connect.

Please could someone advise how to repeatably connect a Mini V3 that is already registered to an AP that is NOT available?

The customer can direct connect with BT. I noticed he had renamed the BT device to ‘CR800’ which I assume has no bearing on the above WiFi problem. His Mini V3 is running the latest firmware.

I don’t understand the Failed Connect to Wifi Solutions: " 3. Try to reset the device, press the power button 3 times entering the reset. Wait for 1-2mins, when the white led blinking slow then you can start to pair WIFI again." Is there a way of factory reseting the Mini V3?


Hi Simon, yes there are the new settings of the black mode button.
-When power up:

  1. Click once to switch modes
  2. Quick click 2 times could repair the WiFi(and the light will blink slow), so you can pair the new WiFi under this status
  3. Quick click 3 times will enter reset(Light will blink fast then go to slow)

You can try point 2 nad 3 for the solution, more for reference here.

1 Like

Hi guys,

i’m having a real tricky time with my A50’s at the moment.

I have 5 A50’s around the house running various ceiling speakers, all set up and all named, working just fine from my phone via 4stream. Until around one week ago. I now can’t see any of them in my app, in my Airplay drop down etc. I can’t reconnect them to the app/wifi regardless of resetting each device multiple times.

I feel like my phone (my wife’s phone is acting exactly the same) may have updated and something has stopped commas with our A50’s.

I use iPhone 11 and it’s IOS 15.3.

The only way I can currently communicate with who of them is via Spotify connect, however these two (out of the 5 on the network) are still completely invisible in the app/airplay devices menu.

Any help would be great, although keep abbreviations to a minimum as I’m not that techy.



Thanks @Joy. I now have a happy customer :grinning:

there is huge bug does not let you use your router`s wifi password has symbols never connecting router… try yourself use /# on your routers wifi key (password) then try connect… this is almost 3 years like this !

It is same issue in my Arylic A50+, only difference my phone is Samsung S21 FE.
I tried in several devices, android app can’t see the devices in my network, but iphone and ios devices can see. I reported this issue to Arylic.

In my case helps following commands:
!!!->can type any Name, use only latin symbols

Before I connected to my device via browser using LAN connection
In such way recomend to change following
“DeviceName”: “SoundSystem_PRO”, “GroupName”: “SoundSystem_PRO”, “ssid”: “SoundSystem_PRO”
This command help to show, what records right now on device device IP adress)/httpapi.asp?command=getStatusEx

I cannot overstate how much I regret buying Acrylic devices. After moving and changing wifi systems, I have multiple S50+ boards that absolutely will not connect at all anymore. They are complete e-waste at this point. If anyone runs across this forum thinking of buying them, run the other way.