B50 /BP50 Firmware Version Update 0057-5be7aedf

Hello everyone, we are going to release a new version of B50/BP50, the following are the changes and fixes of B50.

Updated February 21, 2024( Fixed the issue where the device kept jumping to standby after the upgrade.)

This time, we will release the new firmware:

model fw md5sum
B50 0057-5be7aedf 70bf5b619b83dc5e23b5e911a584a91f
BP50 0056-0bf6cc3e e688fa3599e8aac3ecf8f0b9cc6b5a13

B50 changes:

  1. Fixed, pop noise in optical/coaxial output when power up in Bluetooth mode

  2. Fixed, volume changed when switching between Bluetooth mode and other modes

  3. Fixed, crossover frequency did not save when next boot

  4. Will save the LED status after power off

  5. Add Virtual Bass switch and support to adjust the cutting frequency

  6. Fixed, device crash with some special songs on USB

  7. Fixed, pop noise when disconnecting TX.

  8. Fixed, pop noise when enter standby with remote control

  9. Fixed, wrongly selected USB mode sometimes

  10. Fixed, can’t switch mode sometimes

  11. Fixed, pop noise when disconnect TX device

  12. Fixed, did not show volume in TX mode

  13. Fixed, EQ settings is not saved

  14. Will show current volume approximately with the LEDs in front

  15. Support shuffle mode in USB playback

  16. Will deactivate the crossover filter when connected TX

And, we optimized and added new functions on Go Control App:

1.Support to work with our WIFI based models: setup WIFI, play control, now playing, current queue, etc

2.Show current playing song when playing USB disk

3.Support to set crossover frequency without steps

4.Login interface, USB playlist, custom EQ and other optimization

Hello everyone, we have released new firmware that fixed an issue where the device kept jumping to standby after upgrade. :blush:


Well, thank you for ruining my B50 with this “update”.
After following the procedure, it now flashes STBY and
BT and is not working.
Is there a fix, will you be replacing it ?
Best Regards

I too am having this issue. I am hoping that there is a solution. Otherwise it is a very expensive paperweight.
Just to be clear my issue is with the B50.

Guys, I might have found the problem: The download links posted are reversed. The one for B50, the filename says BP50 and vica versa.
So if you’ve updated using the wrong file for the hardware, it might be why. Maybe try again with the other one.

I’ve just updated my BP50 using a 512MB USB formatted to FAT. And for me it seems to work.

EDIT: It seems the link are now correct. I’m certain the file said B50, when clicking rhe BP50 download link. Anyway, always confirm the filename.

No, the links were correct, I had thought that, but checked. The problem is as the comment from mfoguete makes clear, it is not possible to switch input to usb to even begin the flashing procedure.

I’m hoping the OP will respond with some clarification very soon.

Interesting. I looked up the guide trhat was posted with the previous fw update for B50, and followed that, it worked fine for me.

I opened the app first to get ready, then plugged in the USB and it popped up in the app, if I wanted to upgrade the fw.
Although I was scared and sceptical, having read your comments first. But I tried and it worked…for me at least.

Hi, it’s a B50.
my mistake.

Hi have you been able to unbrick your B50?

So far, no.
It seems to be stuck in a loop.
The downloaded file is correct, and did
follow the previous procedure.

As did I. I’m finding the radio silence troubling… although timezones…

Welp, I wish I would have read these comments a few minutes ago. I too am now bricked after trying to install this new firmware. The lights flashed multi-colored, and now I’m just bouncing between bluetooth and standby over and over.

Would love a response on where we go from here…

Ok that’s 3 bricked devices, so I can assume that we all didn’t mess up and the error is in the firmware. I really do hope to hear something tomorrow morning.

I can confirm that I have a B50, and used the firmware labeled as being for B50 both in the link and in the filename (ARYLIC_B50-0056-0bf6cc3e-20240130.MVA).

I was running stably on firmware version 52 prior, and as such was able to use a USB stick formatted as Fat32. The app picked up the new firmware right away after plugging in the USB stick and asked if I would like to update. I said yes, the lights flashed, it rebooted and now I am in the boot loop.

That is exactly the process I followed and I am in the same position.

I’ve had a look online and there are images of the main board with what looks like UART pins, so I imagine it may be recoverable, not easy and probably very stressful for the average consumer and certainly not what you would expect from consumer audio, but recoverable. I have looked on the main site and I can find nothing about warranty.

I sent in an email to their email address they have listed here: Warranty

I guess that’s the best we can hope for.

Alright, so we got Bricked B50s wheresas mine is a BP50 and has updated correctly. So by the looks of it, it’s only the B50 firmware thats broken. But we need more people to confirm successful P50 updates, to be certain.

I know it’s an abvious question, but have you guys tries hard ressetting on the back? Or does that not affect the firmware?

I tried holding down the reset button. Holding it down with the power unplugged and then plugging it back in while still holding it down. Clicking it. Clicking it twice, etc. Nothing seems to help.

Fun discovery, the volume knob will interestingly still cycle between the different inputs for a second or so before it drops back to “standby”. Not sure this matters, but it’s something.

What about rolling back the firmware to the previously resleased version here on the forum. I read somewhere (can’t remember if it was the user manual or somthing) that you can update the firmware by doubble clicking on the wheel when in USB source (for when not using the app). So if you get the old firmware on a USB stick like normal, and in those few seconds MAYBE can get the update started before it crashes again?? Just an idea

I’ll try it, but I really doubt that’s going to work. The device hard resets after ~1sec no matter what I’ve done so far, but I’ll give it a try for science.’

Edit: Nope, not even close. There appears to be no way to do much of anything, including rollback. It’s pretty well hard-bricked.

The volume control will not change the setting, so you can’t get to the USB selector. The reset button does nothing. I have tried every permutation of pressing/holding, triple pressing etc. and nothing.
The app is next to useless, it connects/then disconnects then hangs and reconnects.