B50 /BP50 Firmware Version Update 0057-5be7aedf

Just discovered something:

My firmware file was named ARYLIC_B50-0056-0bf6cc3e-20240130.MVA, and the app also stated this as an update to “Firmware Version 56”. However, the title of this thread is for firmware 0054, and the version numbers don’t line up.

The firmware files attached to the links are 0056-0bf6cc3e, but they’re labeled as 0054-cf9b19fb. They seem to have attached the wrong firmware… I wonder if 0056 is alpha/beta firmware or something.

I can confirm that my BP50 updated correctly also. I freshly formatted an old 4GB USB drive to FAT16, copied the unzipped .MVA file to the root directory so it was the only file on the disk, and finally plugged it in and opened the GoControl app. It prompted to apply the update saying “version 56 (current 52)”, and I hit Confirm.

The app now confirms it is on: Firmware Version: 56-0bf6cc3e-8

Yes, the links for BP50 firmware also appear to be version “56” as well. So either the text description in the forum thread is incorrect, OR the links given are for a newer version than “version 54”.
The BP50 device upgrade was successful for me, so I guess we’re lucky it didn’t brick it.

The HDMI ARC power on not working when in standby issue, the turn off ARC Standby in iOS app not working issue, and the silence glitch issue are still affecting this version of firmware (details here). I was hoping maybe one of these might have been fixed but it’s not in the release notes so maybe next time. :crossed_fingers:

Mine is 56 as well

I contacted support and the chat rep just linked me to the Firmware version 52 post and said “try this firmware”, to which I replied “Yeah… How do I do that if my device won’t boot?” He didn’t have an answer, so he pivoted to asking for my order number to check on my warranty status. I told him I bought it through Amazon, not their website, to which he said I should then instead email rachel@arylic.com.

A bit concerning that he was checking on my warranty, as for a bricked firmware release it seems like a fix for the affected units should somewhat ‘transcend’ any one persons warranty, but I digress. Nevertheless, he also said that he passed along the report of the broken firmware to the tech support team, and they would eventually reach out on this thread with more info.

Hi everyone, I’m sorry I wrote the wrong version number. :confounded: Changed to 0056-0bf6cc3e. After seeing your question, Are your steps wrong?I feel it is necessary to add a few points:

  1. If the U disk does not jump to U disk mode after being inserted into the device, please remove and insert it multiple times;
  2. After inserting the USB flash drive and the device’s LED light turns on, you can also quickly press the knob on the front of the device twice to upgrade.

Hi Joia,

We are not having an issue with the device recognizing our Flash device. For those of us with bricked devices, we each plugged in the USB device, the app notified us of the new firmware version, and we hit “accept” within the app - at which point the upgrade process began, flashing the multicolored led lights. However, for those of us with B50’s, instead of the device rebooting back to a working state, our devices instead keep rebooting themselves 1 second after they turn on.

What we all see is that the red “standby” light is lit, then it switches to the blue “Bluetooth” light, and 1 second later is switches back to the red “standby” light, over and over again. This is a good-ol-fashioned boot loop.

Pressing the knob on the front of the device does absolutely nothing to help here, as the device isn’t able to boot. The device is stuck rebooting over and over.

Here is a link to a video I recorded of what we’re seeing:

Hi bwyazel
OK, thank you for your feedback. Please send the machine back for repair and our technical department will analyze the problem.

Sure, is someone going to contact me (and the others) with instructions on how to do so? Will we be sent a shipping label?

Also, I’d probably recommend taking down the B50 firmware files before more devices get bricked while you’re investigating. Otherwise, you’re going to have a lot more unhappy people. So far you have 3 people with identical problems, all with the same device and the same series of events.

You should also probably update the title of this post to reflect version 56 rather than 54 like it says now.

I own a B50 amp.
I copied the unzipped file on to 4GB USB drive formatted to FAT (this is the same USB stick I used for the previous update) . Inserted the USB stick into the slot. The device recognized the USB and the LED light of USB was on. I opened the app. But there was no prompt of new firmware update. Tried several times. But no success. Fortunately the device did not brick and it is working fine with the previous version of firmware.
Any help?

I tried the USB stick formatted FAT32 also. But no success.

Hi Joia

My B50 is in the same state as the video, flashing between Standby and Bluetooth.

Does this offer to send in for repair extend to all the other bricked units? I’ve received a very short email from info@ asking for purchase details. Which I do not have.

I would have thought the email would have started with even the most basic “Sorry you’re having an issue… Let’s see how we can help”

Can you provide a little more information on how or what the next steps are?


Hi optionaltoast
We are sorry that our after-sales service has brought you a bad experience. :confounded: I will ask them to contact you to confirm the relevant process of the after-sales order. :blush:

We will keep your suggestions. After receiving the machine, we will analyze whether the problem is caused by the firmware that causes the machine to power on and standby repeatedly. Thanks again for your feedback. :grinning:

Hi, will you keep us posted on your progress wrt. return. I can’t speak for mfoguete but I would very much like to know how this progresses.

We did a mass upgrading test on about 20+ B50s in office and all seems fine, and we’ll test more tomorrow. For now, seems not a common issue. I’m not sure what’s wrong with the dead loop device, but we remain this thread first. And we do have removed the new version notification on APP, so no more users would notice this new firmware. I guess users focus on this forum should be brave enough to try :sweat_smile:

And btw, could you guys help to try this? @bwyazel @optionaltoast @mfoguete
Power on, and connect B50 with PC, and when B50 boot, quickly select the PC mode directly with remote before it reboot, and see if the device could stay alive.

Thanks for the reply. I’ve tried what you suggest and even with the PC button pressed on the remote at boot time nothing changes, the device flips between stby and bt as shown in the video.
Happy to try any and all solutions you come up with.

For info. when I lsusb I get

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:2744 Microchip Technology, Inc. (formerly SMSC) Hub
Bus 001 Device 003: ID 0bda:5411 Realtek Semiconductor Corp. RTS5411 Hub
Bus 001 Device 005: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)
Bus 001 Device 006: ID 0bda:5411 Realtek Semiconductor Corp. RTS5411 Hub
Bus 001 Device 007: ID 046d:0aaf Logitech, Inc. Yeti X
Bus 001 Device 008: ID 320f:5055 RDR ZUOYA GMK87
Bus 001 Device 009: ID 041e:3272 Creative Technology, Ltd Pebble V3
Bus 001 Device 010: ID 046d:c53f Logitech, Inc. USB Receiver
Bus 001 Device 018: ID 046d:082d Logitech, Inc. HD Pro Webcam C920
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 174c:55aa ASMedia Technology Inc. ASM1051E SATA 6Gb/s bridge, ASM1053E SATA 6Gb/s bridge, ASM1153 SATA 3Gb/s bridge, ASM1153E SATA 6Gb/s bridge
Bus 002 Device 003: ID 0424:5744 Microchip Technology, Inc. (formerly SMSC) Hub

The amp isn’t even recognised as a USB device

Yes, it’s only recognized when the USBDAC mode activated. Please try to plug the USB disk in device and see if it could switch mode.

And I’ve read @bwyazel could switch mode before reboot. Could you try to switch to PC mode?

Yes, I understand. What happens is if you press and rotate the volume knob the lights will light up across the amp in order, unfortunately it is not persistent.

So I can try and select DAC when the device boots up, but 9/10 I can’t reach the DAC setting before it loops into STBY and BT and the Remote is not working at all. I’ll keep trying.

This is feedback from one kind hearted user, he’d like to see the current volume percentage with the LEDs. :sweat_smile:

Thanks for the effort, there’s always big surprise out of the R&D office …