Volume control issue

Hi,
This post is to help others if they encounter same issue.

I recently had an issue develop where I could not control the volume at all.

Using the app on the phone whether I went up or down, the only change is when I hit the volume bottom
(0%) that turned sound off.

At a guess they seemed to be all defaulted to 75% volume.

The gear:

  • 4 x AMP v4 - fw: 4.6.415145.35
  • 1 x MINI V3 - fw: 4.6.415145.35
  • iPhone 11, OS 15.2.1

What I tried:

  1. re-install the 4stream app
  2. power cycle the central 24V power supply i.e turn off for a bit then on again

What fixed it (via the 4stream app) was to reset to factory defaults, and re-add the devices.

On app:

  • Devices → settings(gear wheel) → Speaker Info → Restore Factory Settings (right at the bottom)
    remember to remove devices from any synchronised groupings to see the above option.

Hopefully this will help someone if they come across the same issue.

What caused it… no idea, as there had been no obvious change, unless there was an auto-update of either 4stream app or device firmware

Best Regards,
Jason

Hi Jason,

Got the same problem.
I already found by myself that factory reset was the only way…
But the problem is coming back every day… and everyday i reset the AMP to factory defaut… so boring…
Any ideas ?

This is unexpected… did you reset factory on app?

Same issiu here, factory reset helped for now

i reset from the app on android. but issu still coming back every day :frowning:
is there any way to hard reset or maybe reinstall the firmware ?

Same for me now today the issue came back. My devive is so no more usable .
Hint. I switch off the power.

Same problem on my AMP V4. This happened after the new firmware update. The factory reset helped for now…

Hello, the same Problem on my Up2Stream Amp Mono!

After installing the firmware 4.6.415145.35 the volumecontrol is only digital. Zero or max.
Factory reset only work until restart the amp.
Reinstall Mobile app doesn’t have any effect.

I tryed spotify and internetradio. 4STREAM App and WebApp.

In the HTTPAPI…getStatusEx are the following informations:
firmware: 4.6.415.145
hardware: A31
build: Release
project: UP2STREAM_AMP_V4
project_build_name: a31rakoit
Release: 20220427
branch: A31_stable_4.6
wmrm_version: 4.2

Please help me. The device is unuseable in this status.

Thx Stephan

So, it seems that the last firmware have a problem ?
Could we have an answer from the arylic team to know what to do now because it’s actually unusable like this.

R.B.

It should be a problem, I’ll look into it ASAP.
I can’t catch this problem on my board…
could you check the config with the TCP tool ?
Connect to device with IP, and send MCU+PAS+RAKOIT:VOF& to check the settings, and could send MCU+PAS+RAKOIT:VOF:0& to disable it.

ok, so when i send the command, it return “49&” (sound is loud and the fader volume doing nothing, i can just mute the sound, i can see the activity of changing volume on the TCP tool but no effect on the sound)
when i send the command VOF:0& it’s definitively mute the AMP.

what it returned when you send MCU+PAS+RAKOIT:VOF&?
I want to check if it’s caused by this config.

for the rooms that works it returns :
MCU+PAS+RAKOIT:VOF:0&

for the room with issu it returns :
MCU+PAS+RAKOIT:VOF:49&

After (re)start the amp the command: MCU+PAS+RAKOIT:VOF&
returns MCU+PAS+RAKOIT:VOF:49&

MCU+PAS+RAKOIT:VOF:0& works and mute the device
MCU+PAS+RAKOIT:VOF:10& volume level one step higher
MCU+PAS+RAKOIT:VOF:20& volume level another step higher
and so on …

Wenn control the volume level via app:
At level 0 the return is:
AXX+SIL+001AXX+MUT+001
AXX+VOL+000
No music is hearable

One Step higher (max loudness again)
AXX+SIL+000AXX+MUT+000
AXX+VOL+003
AXX+MUT+000

Nother Step higher (without effect)
AXX+VOL+006

Nother Step higher (without effect)
AXX+VOL+009

and so on

Btw i think there is no link but at the start of the amp the finish start sound (ding) and the wifi connect sound (connected to your wifi network) is missing :wink:

Just want to chime in that having the exact same problem. Resetting daily to have volume control is not a viable option. Pretty annoyed that a product working perfectly now has an issue that prevents any use at all.

Same problem here although it happened recently. My family members don’t care what causes it, they want a reliable system other than Arylic. Repeatedly fiddling with reboots, factory resets, etc. makes the pleasure of listening to music quickly disappear for non-techies. Semi-automatic updates leave the end user with surprises again and again due to the “improvements” that make a previously functioning system unusable. These beta firmware OTA updates are a constant source of irritation. A Spotify upgrade would be worthwhile, many other fixes are not.

Greetings

Sorry about the mess, and thanks for helping to debug the problem. The issues seems caused by the wrong configs loaded. For example, VOF stands for Fixed VOlume, and it should accept only 0 or 1, or else invalid. The value 49 or 10 is actually not expected. And the settings is supposed to reset while you do factory reset on APP. Might be some bug in firmware or inconsistant flash. I can add extra verification for these settings and remove unexpected values at least.

No problem, I like to help more :slight_smile:

You say: wenn I change the VOF to 1 and send the VOL+ command, it would be work?

I have not tested the VOF 1 setting. Only 0, 10, 20, 49.
But I wonder why VOF in greater steps change my volume in normal amount.

I think the VOL command doesn’t change the volume attribute anyway.

I will check it these afternoon.

Hallo ook hier het volume probleem graag update firmware zo niet kan ik terug naar vorige versie nu kan ik geen gebruik maken van product