Unable to complete first time usage wifi setup of Up2Stream Mini

I purchased 2 Up2Stream Minis in January 2021 and have only now got around to trying to set them up. These are obviously older models and I have 2 giving the same problem so not a faulty hardware issue.
I follow the instructions for first time setup and can successfully connect to the devices AP with my Android phone (Galaxy s22 running Android 12). I use the 4Stream app to enter wifi SSID and password. I get the message that the device is connecting to my network but after a minute or 2 I get “connection failed UH OH! Please check if the Wi-Fi password you entered is correct…”. I am very close to the WiFi router.
I have tried using a different phone running Android version 9 and get the same result.
I have tried a number of times, have long pressed the power button to go into setup mode, have held the power button down while connecting power, have double pressed the power button and triple pressed it. (It did occur to me that there should be a “reset” button as per instructions but I can only find a “power” button).
I am now out of ideas and would appreciate any help.

Hi Charliepapa welcome to the forum.
Have you checked out the FAQ section? There is a post that might assist you. Cannot Connect to Wifi


Thanks Steve - yes I did see that post. It recommends usin BLE but also says the Up2Stream Mini does not support that - so I am stuck using wifi. I followed all the steps in the post (noting that I must use the 2.5G network not the 5G one for initial setup).
I also tried all the suggestions for when the connection fails. Using a LAN cable sounds like the best solution but these boards don’t have a LAN socket.
Still stuck but very keen to get this working…

…the post goes on to say that if all the suggestions fail then it must be a hardware issue but in my case that seems unlikely since both my boards have the same problem.

Maybe try restarting your router and or bringing the devices closer together to get maximum signal strength?

I’m only a metre from the router, restarting it didn’t help but you made me think there may be a firewall rule preventing comms. I will look into that but any ideas would be much appreciated.

Maybe then temporarily disable the firewall and see if it solves the problem. It may need some tweaking of the settings?

It seems the firewall is not the problem but there may be a wifi setting causing a problem. I swapped out my Mikrotik router and replaced it with an old router that was lying in a cupboard. I was able to do the initial setup successfully and I updated the firmware. However when I reinstated my Mikrotik router the board was unable to connect - even with the latest firmware and the initial setup done.

Below are the wifi settings of the Mikrotik router. I do not understand 90% of these settings but hopefully a network engineer could comment and suggest what I could change without breaking anything.

Name 2GWiFi
Type Wireless (IPQ4019)
MTU 1500
Actual MTU 1500
L2 MTU 1600
MAC Address B8:69:F4:33:4F:83
ARP enabled
ARP Timeout

Mode ap bridge
Band 2GHz-G/N
Channel Width 20MHz
Frequency 2432MHz
SSID hunternet
Security Profile iotSecurityProfile
WPS Mode push button
Frequency Mode regulatory-domain
Country new zealand
Installation indoor
Default AP Tx Limit bps
Default Client Tx Limit bps
Default Authenticate yes
Default Forward yes
Hide SSID no

Tx Chains chain0 yes chain1 yes
Rx Chains chain0 yes chain1 yes
AMSDU Limit 8192
AMSDU Threshold 8192
Guard Interval any
AMPDU Priorities 0 yes 1 no 2 no 3 no 4 no 5 no 6 no 7 no

HT Supported MCS MCS 0 MCS 1 MCS 2 MCS 3 MCS 4 MCS 5 MCS 6 MCS 7 MCS 8 MCS 9
MCS 10 MCS 11 MCS 12 MCS 13 MCS 14 MCS 15 MCS 16 MCS 17
MCS 18 MCS 19 MCS 20 MCS 21 MCS 22 MCS 23
HT Basic MCS MCS 0 MCS 1 MCS 2 MCS 3 MCS 4 MCS 5 MCS 6 MCS 7

WDS Mode disabled
WDS Default Bridge none
WDS Ignore SSID no

Enable Nstreme no
Enable Polling yes
Disable CSMA no
Framer Policy none
Framer Limit 3200

I could be wrong, but I’m thinking that the mini’s MAC address is probably not on the routers approved list?
Someone with a little more networking experience than I might be able to confirm this and explain how to rectify.