No music when link Rooms together


When I link my rooms together in the App I get no sound. Individually I get sounds just fine. It does not matter if I group 2 or 5 together This happens for all sources of music. I have five Mini’s on firmware 4.6.329454.29. I have unplugged and restarted all of them several times.

The “Master” with source of music should be 1st in Grouped list on “Devices” screen and all “slaves” below it
with all in single border. My master when grouped shows modulating bar graph under it’s source followed by “Group volume”, then "Master volume slider, then each slaves slider

Yes, mine is setup like that, but still no sound

What’s your music source?

What’s 4stream ver., what’s it running on & phone version? ie IOS13

What’s your connection between Master & slave, WIFI? ethernet?

As a test, turn down the volume to zero, then turn it up again. it was a solution for me in a similar case.

I am running IOS 15.02. All devices are Wifi.
4STREAM 2.8.10122

Did that still nothing.

Post screen capture of 4stream with everything grouped and input selected and not playing.
You didn’t state your source of music

There is no music from any source when grouped. I grouped all sources play fine.

The source in this picture is Airplay

@flipper Tracy,

It’s really difficult to debug so many different Hardware & Software. A drawing that I have found very useful in the past is shown below. It is from DLNA Documentation but also applies to AirPlay, Google Cast etc.

Sorce Sink Control Point

Some Examples
Source = Internet Radio, Music Server, Music Service etc.
Sink = Arylic Device, TV, Laptop, Tablet, Phone etc.
Control Point = Phone, Tablet, Laptop
Transfer Protocol = DLNA, Airplay, Google Cast

In the extreme examples Source, Sink & Control Point can be the same Device
e.g. IPhone Audio App playing locally stored MP3 file on device, sound coming out of the Phone

Source, Sink & Control Point Can all be different Hardware:-
e.g. Control Point = iPhone, Source = Spotify, Sink = Arylic Device.

So another thing to understand is that the Arylic Multiroom is Completely independent of the Above.
e.g. The Sink in your case is Master Bedroom Audio with Garage & Family Room as Slaves Audio Outputs. If you confirm that your Problem does not happen in Single Mode to Master Bedroom Audio then the problem might lie solely in the Arylic/LinkPlay World. Can you confirm this is the case ?

Another detail to consider in the debugging process is if you are Pushing (e.g. selecting Music from Spotify and pushing it to Arylic Device) or Pulling (e.g. using the 4Stream APP to PULL some music from TIDAL Music Service). What is your case ?

FYI I have no real experience using Airplay with Arylic Products. A long time ago I used to use Airplay Airports & Apple TV pre DLNA & Google Cast. For my needs I have settled on DLNA as it is published, transparent and not closely controlled by one equipment manufacturer (e.g. Apple, Google).

Airplay is quite old now too and has certain limitations including the main limitation that it has been reversed engineered to work with Devices like Arylic. Whilst I am sure that Arylic or someone on the Forum can solve your problem it may be worth considering futureproofing using a different method (of course with you existing Hardware that you have chosen).

I think the way to offer solutions is as @CAT22 Steve is suggesting. We need to know the Source and Whether you are Pushing or Pulling.

Hope this helps, Kevin

P.S. I have a iPad and a several Arylic Devices so I can replicate your situation if I know the Source & the Control Point :slight_smile:

P.P.S. Hope the tutorial was helpful for you understanding however I have just noticed that you have 5 MINIS. These are Wifi Only. I don’t know how the Multiroom is achieved in the Arylic World. I will Investigate. Also to be fair it is not Arylic that designed this. That is Linkplay. So a total “punt in the dark” is a internal firewall/router issue. Try to disable the WLAN Firewall in your Router just to see if anything improves .

Thanks for the info. I have tried all of the above. I have pushed music to the devices from itunes, I have pulled from Amazon, Pandora, I heart radio. So I have tested all sources. This worked before for me. I feel since the last update that got Airplay to start working again the grouping stopped working.

1 Like


It seems to me that the problem is firmly on the Linkplay/Arylic side of things. Hopefully the new firmware update will fix this for you :crossed_fingers:

Regards, Kevin

Yes, Hopefully

Thank you for your help!

Not to leave out the obvious, when under group play the individual units are controlled from the 4Stream “Group Volume” slider which in turns interact if individual sliders are adjusted. The image you sent show extremely low setting. I simulated the 10% sliders on my system and get faint audio. I have A30 & S10 (latter driving 3rd party amp via S10 “Aux Out”) with aux input on S10 for master and I’ve got S10 set to 50% at all times.
the mini doesn’t have Aux In but can you test with USB drive on your Master Bedroom mini playing ungrouped but controlling via 4stream for functionality and then group with any slave and try to adjust master which I assume is connected to external amp via “Aux Out”?

1 Like