New update causing iTunes Airplay Issues

Hi All,
I just update to the new app on my phone and now when I try to use Airplay from iTunes on my PC. All my Arylic devices are playing my music with the sound going in and out. I have tried almost every scenario. The one that works good from Itunes is when using the USBDAC option for one of my devices as it is connected directly to the PC. Amazon, Pandora and other services work fine. So its not my WIFI Any ideas on why?

Hi flipper, sorry, I’m not get the problem clearly, could you describe it with more details, like what you did, and what happened.


When Airplay/Wi-Fi is the master source for each individual source it is unstable when I am playing from iTunes Airplay on my PC the music

plays for 2 seconds and then stops for 2 seconds and plays again for 2 seconds. It keeps doing that forever. and also yes when Airplay is also the Master source under multi room and playing it is unstable. Music plays for 2 seconds and then stops for 2 seconds and plays again for 2 seconds. It keeps doing that forever.

Hi I am also using airplay (wired network with Roon) and i also plays for 2 seconds and then stops for 2 seconds and plays again for 2 seconds. It keeps doing that forever.

Strange, I ever tested with airplay playback for more than 4 hours without any pause. I’ll check it again tomorrow.
And have you grouped devices with the one which receiving the airplay stream?

Yes, I have tried lots of different scenarios and they all do the same thing when playing Airplay from my PC. I never had this problem before. Only after your last software update is when it started

1 Like

Also, in the last update, Was there an update to the version of Airplay maybe? Is there anyway we can go back to the old version of software?

1 Like

ok, I’ll test the airplay tomorrow. And we can’t go back as time flows :slight_smile:

Ok, Thank you

Its the same here. I just got a S10, and it updated the fw, and my playback is 2 seconds on and 2 seconds off when using airplay from Itunes on windows 10. I do have a A50+ that hasnt been updated and that is working perfect with old fw…and tried again after writing this post, and the same thing happened, AND when I let it play, it reboots.

Me too!

I’m Airplaying from Roon and it’s fading in and out at a regular two second pulse.

I can airplay from the Tidal app just fine.

I am experiencing the same issue with Airplay from my PC running ITunes. 1 to 2 seconds on and the 1 to 2 seconds off. Continuously. Is there a way to downgrade to the previous version until this is fixed?


I’ve the same problem from the last firmware

I try to update to the beta but the problem is the same.

It’s working when I use tuneblade on windows.

But lms with the airplay bridge plugin and the android app “AirMusic trial” does’nt work ( 2 seconds on 2 seconds off )

Same issue here. Using Roon or Apple Music

Airplay - 2 seconds on 2 seconds off

Direct stream from Tidal or Qobuz - no issues - but Apple Music (via Airplay) an issue

Firmware 4.6.328252.7

And as an update on my problem:
To be sure that it wasnt my PC that had a problem, I replaced my S10 with a RaspberryPi running shairpoint-sync and AirPlay from PC/Itunes works perfect, so that will be my setup for now.

Same problem for me. The S10 works just fine with iPhone and tablet - but not with MacBook pro running apple music - same issue as above - plays for 2 seconds - stops for 2 seconds etc can anyone suggest a fix - or is this a firmware issue?

This is definitely a firmware issue. I did not have this issue before the recent firmware update. I am hoping Joy or Frank is working to fix this.

I can confirm the AirPlay-issue. I’m using two S50pro+ and since the update on both devices AirPlay is not longer useable. I’m using Android-Tablets and Smartphones with full-version of AirMusic and doubleTwist. Before the firmware update everything was running fine, directly after the update the problem described above occurred. Too bad! I hope for a quick fix. Thanks in advance!

In trying to diagnose my stuttering problems when using either an S10 or S50 via Roon, I have just found this thread. I confirm I have exactly the same problem. However, I can stream directly from Qobuz to either the S10 or S50 and not have a problem.

Dear Arylic Team,
is there any way to manually downgrade to the old firmware? It’s really no fun to play around with non-functioning hardware now. Or are you working on another update? Thanks in advance!