Firmware Upgrade 4.6.415145.35- Up2stream Mini V3, Up2stream Amp 2.1, Up2stream Plate Amp 2.1

This article summarizes the changes for specific Models Up2stream Mini V3 , Up2stream Amp 2.1 and Up2stream Plate Amp 2.1 firmware release on May 26.2022.

Newest Firmware Version

Up2stream Mini V3, Up2stream Amp 2.1, Up2stream Plate Amp 2.1/ 4.6.415145.35

New Features

  1. Add preset EQ, Flat/Classic/Pop/Rock/Jazz/Vocal
  2. Support gapless playback
  3. HTTP API for playing notification
httpapi.asp?command=playPromptUrl:[URL]
  1. Fixed, HTTP API reboot not working
  2. Adjusted default volume step to 5
  3. Adjusted minimum MXV to 30
  4. Add extra IR code for power on and power off
  5. Will reboot the device and enter WIFI mode when the sleep timer is out, to avoid the system not responding on standby.
  6. Add -BLE appendix for BLE device name to distinguish with classic Bluetooth
  7. Sync VB settings when set in ACPWorkbench
  8. Fixed, can’t switch to LINE-IN mode on boot
  9. Fixed, connected BT device is not forgotten when factory reset
  10. Fixed, used treble value for bass on boot
  11. Fixed, SPDIF input voltage level
  12. Fixed, system detected silence when input level is low

Web Player New Features:

  1. Personal Radio
  2. Audio Settings
  3. Need password for the whole page
  4. Set title for page

hi, I did the firmware update (Up2stream Plate Amp 2.1). where can I find the preset EQ, Flat/Classic/Pop/Rock/Jazz/Vocal?
Thanks in advance

Hi, in the web interfaz, usin ip of device in the web brousers.

Regards.

Thanks for the answer
unfortunately that doesn’t work for me.
the website hangs like frozen.
It would also be much better to be able to control this in the app.

Do a factory reset on the device with the 4Stream app. You will need to setup the wifi again. You may also need to delete browser cache. I had to factory reset one of my devices 2 times before the page worked correctly.

I am unable to use the new EQ settings. It isn’t clickable. Any help would be greatly appreciated.

Thanks for the awesome updates to the firmware!!

1 Like

Hi, infat, the correct way is via app.

Regards.

Hi!
Unfortunately my web interface is frozen like @Stefan_Zintel

Edit: New firmware works after factory reset

Cheers,
Niels

It works great, it remains to finish the 4stream application for Android

Thnx, great we have an update!
I have two questions:

(1) What exactly means ‘gapless’, or how will I notice gapless? Does it mean there is no time needed for buffering when starting to stream audio?

(2)

Does this mean that increasing/decreasing volume works in smaller steps?

(I am traveling, so i can’t check the changes myself)

Hi, since upgrading to this firmware I notice that after a while connected to wifi, the green Line in LED also lights. Audi doesn’t appear to be affected. I’ve seen this on 2 different up2stream2.1 boards now. What does it means and is it a problem?

@Joy
Volume: so the steps are now smaller?
Gapless: can you please give a comment what exactly gapless means in this case?

(Just wanna be sure I understand right :slightly_smiling_face:)

Gapless playback means listening to Live albums or mixtapes without annoying silence or ‘gaps’ between the songs.

Hi
After the last OTA Update, all my mini V3 boards suddenly start randomly to enter setup mode with the voice output Looping every 20 sec. After power cycle they reconnect again and work just fine but they are installed in my kids’ bedrooms and in the middle of the night start randomly talking.
Never had any issue for a few years now and suddenly after 27th April they all started this behaviour.
Did several factory resets on all of them with new setup. Then works for half a day until it all starts over again.
Any ideas?

Hi Phillip, That’s strange. How’s the connection for the boards? Did you use the ADCKEY? And is there any chance that the board might receive a IR command?

Hi
They are simply powered by a USB Charger and drive a pair of cheap PC-Speakers via 3,5mm jack. IR command would be very unlikely since I have 4 boards in different rooms all showing the same behaviour.
As mentioned, did not have any issue since I installed them like 2 or 3 years ago and since they updated on april 27 they all showed this. so it looks very likely to be some hickup with the firmware.

Another fun fact: they always seem to start within one or two minutes in the morning at 06:00 hrs am and pm. As far as I could reproduce it.
What the heck?

Did you set the router to stop at that time?

No,I checked the log too, not even dsl-reconnect at that time.
Other devices were connected then.
And as I said, nothing in my system changed, it all worked well and from the day of the update it all started.
Is there any way to roll back to previous version to test?

please mail me frank@arylic.com

Ok we so far solved it. My router did some band steering and changed the wifi chanel from time to time. This disconnected the boards which aometimes triggered the setup mode. Although this is unwanted and will be fixed, turning of the band steering for the 2,4GHz wifi solved it for now.