Firmware Upgrade 4.6.337862

@zpl1025 great, that’s a good idea! Unfortunately the browser cache is not a good solution, because if I restart the browser, it will start again with an empty menu.

– Update

I tried the preset list again from the browser after uploading the A50 + presets. All those presets are still empty (at least according to their caption), but if I click on one, the program corresponding to the preset number will start. The web interface does not read the status of the device to me (the current program name, cover image, preset, etc. are not displayed) What could be the problem?

– Update2
Ahh yes, it takes a few minutes for the preset list to be transferred from the device to the browser. It’s not fast, but at least it works sooner or later…

Cycling the power didn’t work, but I upgraded to the latest version just pushed (4.6.337862.27) and it seems to be working now.

Hi, I think the choppy sound with Airplay only happens when you have the browser player view open at the same time. No choppy sound when the browser player view is not open…Hope that may help you.

thanks for the feedbac, we’ll investigate and improve

1 Like


I have 6 up2stream V4 devices and have been experiencing trouble with them since the recent firmware updates. I would like to preface this to say that before the firmware updates I did not have any issue.

My current version for all devices is 4.6.337862.29

1.Some devices will longer display in 4stream after selecting to stream music to it from Spotify. This is a poor experience as I no longer have an interface to enable the multiroom feature since the listing of the device is not visible. Interestingly enough, if I go to spotify and select to listen to the music from another up2stream device or my phone, the listing that is no longer showing up in 4stream is listed in Spotify and can be reselected to stream music. The device does not show up in 4stream again until I power it down and turn it back on. I did not have any issue with this previously

  1. This is an independent issue from the one above. Since the update I can no longer successfully do multi room streaming with 2 specific devices. If I select a Up2stream device to stream the same music to another Up2stream device, the music does not play on the second device. I’ve attempted to do this via the app and the http api but the music does stream to the other device.

I purchased these 6 devices and built a custom enclosure to house them because I believed that they would be a great addition to do multiroom music in my home but recently I am doubting the decision due to the latest firmware upgrade. I hope that these devices can be restored to their previous working condition but I realize that would take another firmware change to accomplish. Please when making changes consider the user/customer and make sure you’re not breaking functionality that your customers have come to trust.

Are there any plans to fix the multiroom issues that have been reported here an in other posts mentioning this kind of issue?

Is there a process that I can follow to revert to a previous version of the firmware?

Please help.

1 Like

This upgrade didn’t fix my digital noise problem in the multi system receiving unit,
when app input is switched to OPTICAL from the SPDIF add-on board, all other inputs sound fine.

Following up with an update. In the second report I mentioned that I was unable to connect 2 specific devices. I was wrong. It is all of my devices. I tested again today. Please help. @zpl1025 or @Joy

I have the same problem. how to see and listen to local collection of mp3 flac music?

Hi joy
I have similar problem each time I switch on a system I have to press DB button on the remote to get good low frequency response. Is there a way of enabling the DB permanently? Since without it the quality of sound is very poor. And it’s very inconvenient to use the remote control on units tucked away

1 Like

Yes. It would be nice. Equalizer settings are saved. For some reason, this setting did not provide for … :frowning:

Please release Tidal conmect!! Please Please please :pray:

Hello Arylic developers, I have a S50 pro+ and I am quite happy with the firmware and user-experience.

The most needed feature in your next firmware releases that I request you to address:

a.) Automatic switching between Wifi and LAN network. Currently it switches from Wifi to LAN automatically, but not reverse. For this you need to restart the device
b.) View the Type of file (mp3, FLAC, WAV), Bitrate and Frequency (Hz) in the display for S50 Pro+ or in the App itself. Indicator used in the device can be shown in different colour for different types of bitrate and frequency.
c.) Shutdown device after a pre-set timer / or no action detected, to conserve electricity
d.) Volume button in the 4stream app.

Thank you.

1 Like

Please remove the USB limitation to 1200 tracks!

Thanks :pray:

Please include DB control that can be switched on or off without using the remote control

1 Like

Hi Christian, for the multi room issue, could you check if all firmware of device are upgraded to latest. And if confirmed and still have the issue, please try the procedure and then send a feedback on app, it will collect some information and would help to identify the problem.

Hello @zpl1025

Since I posted here in the forum 20 days ago, I have emailed with @Joy. We’ve exchanged 13 emails since then but no resolution. Joy asked that I provide the response for the getStatusEx. I sent her an email with 6 json files that include the responses of all my devices. Those Json files will show that each device currently has version 4.6.337862 of the firmware. If you would like these responses please share your direct email address with me and I can send them. Alternatively, you can check in with Joy to get those json files. Joy also asked me to send the feedback through the app, and I did. Below you will find he confirmation numbers from the feedback that I sent in app.


In her latest email Joy mentioned that the engineers have have found this feedback.

Please help, I’d really like these devices to work as expected.

I sent Joy another email on 1/2/2021 to follow up since it had been so long since I heard anything regarding the documentation that I have provided you all. During that time I continued to test the systems and have some additional information to provide, It is not much but hopefully it will help. Below is what I sent Joy in an email 1/2/2021

The multiroom feature is simply not working. Devices never connect. When I select a device to pair I get the spinning icon and nothing happens. The devices do not pair.

In regards devices not appearing in 4stream, I have also noticed that when I enter the ip address of the devices that are not appearing in 4stream in my browser, I never get to the web page. They only reappear in 4sstream when I turn off and turn on the device.

Ok, I just did not connect your post with information from Joy, I’ll check with her.

I mostly use my Up2Stream Amp V4 to power my PC-Speakers.
I would love to get an update (and/or windows app/driver?) that makes it so i change the volume on the device using the windows volume control.

I also have a Up2Stream Pro V3 - Multiroom Wireless Receiver Board (No Amp). Had an idea to use that to make a wireless sub woofer for my PC-speakers, and at the same time hooking up a Sub to my TV using it’s headphone out. But last time i tried that “multi room” wasn’t enabled when the Amp v4 are in USB-DAC mode. That would be a nice feature to get as well.

The Web-Interface looks nice, but for a operate on tablet, it is necessary to make the volume slider much larger, and the multiroom function is also necessary.
Thanks, BR

1 Like