DHCP lease time or static IP

I suddenly have problem on one of my upstream mini V3, the IP always change everyday even i set max for dhcp lease time. I wonder there an option to set static IP. Thanks

@Nasrul A lot of modern home WiFi devices don’t include the option to make Static IP Address. A good example is WiFi bulbs. The “fashion” if you want to manage your IP addresses (which I think is a very good idea) is to do it in the router with a “DHCP Reservation Table”. This will create a permanent IP Address linked to the Ethernet TCP/IP MAC Address. See if you can configure your Router. If not post your Router model number and I can tell you how to do it.

Kind Regards


1 Like

We’re working on it (static IP settings) yet, will make a web page running on device for the settings. Hope to release in end of June.

1 Like

Thank you so much for your respond, my router is nokia which is not support. i have tried also dhcp reservation table at my main AP, but still no change. i was also set dnsmasq on my home assistant
i face this case since i update to the latest firmware. the only way to make my home assistant connected to my arylic is to keep it on.

Great. awaiting for this new update, anyway this is only happened on 1 of my device, the other 2 devices are working fine with max DHCP lease time

Static IP and Web Interface. Works for me :slight_smile:

Didn’t know that home assistant had a dhcp server option. Might try it sometime as the quality of routers supplied with broadband is getting worse and worse :joy: :rofl:

All works now, :grinning:.

1 Like

@zpl1025 How’s the Static IP Web Interface going ? Regards, Kevin

Hi Kelvin, The web management page is almost ready. I’ll update the link in beta firmware post.

1 Like