B50 /BP50 Firmware Version Update 0057-5be7aedf

Well, I will think if I want to be your hero.

Fyi: Same issue after trying upgrading to v56 again with HDMI cable in. Re-downgrade to v52 was possible without problems with HDMI in.

So better not to take a risk. We will wait for Frank to respond.

Looks like I’ll not be upgrading firmware at this time :sweat_smile:

Hello everyone!

Get same issue with bootloop then update fw v52 → v56. HDMI fix worked for me (just plug B50 to PC via HDMI), after that I can startup B50 and downgrade it to v52.
Thank you @arboeh and @Topher52 for research and help! :grinning:

p.s. no comments about silenced support… :face_with_diagonal_mouth:

Hi guys, we’re actually on holiday in the past days, and now back to work now. And thanks for the findings, it’s really good news for me to know that you could revert to old version. And have removed the broken 56 version firmware, I think no need to try now. And I’ll investigate this issue and feedback soon.

Hi Frank welcome back. Hope you enjoyed your holidays. Yes, we all could roll back to v52 after a disastrous v56. I am sure you and your team will check out what went wrong. We will wait.
Thanks.

After upgrading my BP50 to firmware version 56-0bf6cc3e-8, initially everything seemed to work as intended (except of course the pre-existing issues with HDMI ARC and standby/resume). However, today I noticed a new issue, which I’m not sure if it’s related to the firmware or not.

The LED for ARC now does not illuminate when in that mode, nor when changing volume up and down as it used to when on this new firmware (the LED indicator “volume percentage” new feature). It seems as if the LED for ARC has burned out somehow.

Other than that, everything else seems to still be working as before (of course HDMI ARC standby / resume never worked for me properly). Just thought I should share this info in case it affects others, or if it turns out this is related to the new firmware too. If it’s not related, then I guess it might be a separate issue or a hardware defect of some kind affecting my device or model.

EDIT: Over the past few days, I noticed that the LED has come back on (multiple power cycles since then). However, one time it was flickering strangely and now it seems much more dim than the other mode indicator LEDs. It definitely doesn’t seem normal, as when the device was brand new all the mode indicator LEDs were shining at the same brightness, even after the firmware upgrade.

Hi @bwyazel @optionaltoast @mfoguete,The problems you mentioned before have been solved with the new firmware. We appreciate your honest feedback to help us solve the problem.
Thank you!

Hi,
Thank you for the info.
The update was succesful.
The app however has an issue, repeated file names on usb.


Regards

I tested 57 software on B50, seems to work fine (with and without HDMI cable), I used ARYLIC_B50-0057-5be7aedf-20240220.zip file. I updated from 52 software.

The issue with noises during volume up/down on HDMI ARC is still there - when I change volume levels there are moments when sound is either distorted or (in most cases) is falls down to get back to previous level. This is happening only during volume change. This is not happening in Bluetooth mode.

@joia @zpl1025 are you aware of that issue? Is there plan to fix it?

(post deleted by author)

(post deleted by author)

Successfully updated new firmware v57

Successfully updated also.

Hi @mrdarkenrahl ,I just retested the issue you mentioned and it didn’t happen. . Could it be because of your TV. . .

Just updated B50 to v57, no issues, although upgrade process is a bit hit n miss.

Updated to version 0057* successfully. My Samsung TV still doesn’t recognize B50 via ARC :sob: