4stream app no long plays from my NAS

The 4 stream app on my iphone no longer plays music selected from my NAS. I believe this happened after the last firmware update an my Arylic S50 Pro+. I am still able to play music from Pandora and Amazon. The app sees the music on my NAS but does not play any of the selected songs.

The NAS is otherwise working normally. Seems like an app issue.

Any thoughts?

I believe there are some issues after the last update.

Hi @mitchel674

Welcome to the forum. There are many nice people trying to help each other here (for example @Jarrod_Armstrong )

I haven’t tried NAS with new firmware so will test soon. :slight_smile:

Kind Regards, Kevin

Thank you, Kevin.

It’s a shame since I was so happy playing my music from my NAS before this upgrade was pushed. Now when I select an album from 4stream on my NAS, it just scrolls to the last song and plays nothing. Quite a bug in the software which has rendered my new Arylic S50 pro+ useless.

Any suggestions would be helpful.

I have same problem with Libreelec(Kodi) upnp server from beginning,with all linkplay a31 device…just skip the songs to the end of folder,Yamaha streamer don’t have this problem,i use Arylic and August w320 only for net radio :frowning:


I am a bit busy right now but should be able to test and report back sometime next week.

FYI I use Synology NAS where I can PUSH Music to S50+ using Audio Station app, or PULL music using 4STREAM APP. e,g, My Music >> Select Media Server. (NOTE not tested since Firmware Upgrade !!). It certainly used to work both ways :thinking:

So my questions for your problem are -

  1. What NAS are you using ?

  2. Is the problem evident with PUSHING & PULLING Music ?

Kind Regards, Kevin

I have a Synology DS220+. I have only used the 4stream app to pull music to my s50+.

Always worked perfectly before the latest firmware. Now I cannot play any music from my NAS through 4stream app. Just skips to the last song and plays nothing. The NAS is working normally with synology apps.

That sounds exactly what is happening to me now. I hope my S50+ did not turn into a net radio streamer. I purchased it to play music from my Synology NAS.


Try Pushing from Audio Station App. It’s not easy to explain but the pushing and pulling are 2 very different software processes in this situation. Of course the PULL should work however maybe you can listen to your NAS music while Arylic fix the issue :slightly_smiling_face:

I have Libreelec (Kodi) OS install on mini pc,Libreelec share Samba and upnp perfect for another streamers in the house,Yamaha wxc 50,Sonos amp and Yamaha rn301,i try also with another streamers and all work with Libreelec,i have same problem with just linkplay a31 device no mater what app i was using 4 stream,august,audiocast,audiopro…i try them all with august w320,Arylic amp, and Nedis SPWI5500GY with combination of different firmware’s but in last 3 years never works for me,also there’s a lot of firmware’s change in Libreelec platform…also i try using Hifi cast app for android to send them music but same problem with skipping songs without playing them.with new app and firmware says that “no music select”

Unfortunately, the only way I see to push music from my Synology NAS is with their DS Audio app. I would then have to connect to the S50+ by bluetooth from my iphone. This doesn’t work due to the short distance needed for bluetooth.

I hope this 4stream/ S50+ bug gets fixed quickly.

@mitchel674 there is another way to PUSH from Audio Station, The arylic should show up as an available streaming device (DLNA renderer). No BT involved. I can send instruction links but things work slightly differently depending on Music Controller. So Questions ?

Audio Station Controller - UI - Android app, iOS app, Web Browser (on Mac, Windows or Linux) or something else ?

Is the S50+ on Wifi WLAN or Physical Cable = LAN Port ?


@Viktor1212 Victor,

Let’s start with the Arylic AMP.

  • What model ?
  • Connected to Router by Wifi (WLAN) or Hard Wired to LAN port ?


P.S. I used Libreelec (Before Kodi) many years ago for Video Displays in Art Installations with RPI. I have no idea what it looks like now but it certainly did the job at the time :slight_smile:

Please send instructions. I am on iOS and can use the Synology DS Audio app. my S50+ is on Wifi WLAN not a physical cable.

Hi,amp is up2stream 2.0 v3 amp(modul) mostly connected in wifi but remember that i sometimes i connected other linkplay a31 device with lan but with same issue,i don’t believe it’s Arylic problem,linkplay a31 modul on another 3 device act the same with new and old firmware’s,i try it all variants,also on mini pc i have another ready hard drive with openelec older variant of libreelec but always i have same problem ,i suspect that linkplay device don’t recognize file codec of kodi like audio file or something like that(tag),maybe see it like video file and make conflict… Thanks.

Hi @mitchel674,

I could send instructions but on reflection it is essentially Airplay from iOS so you should see Arylic Device as a “sink” for Airplay.

However I thought you would be more interested that I have no problem to PULL music from My Synology via Arylic APP. Home Music Share shows up fine with latest Firmware .

I don’t what could have changed but I do know Security Updates from Routers, NAS Drives, and Equipment could possibly close down previously open Communications (Particularly with WLAN).

A good test is to use LAN port with cable (just to find out what is going on). That will certainly clearly the Router & Arylic Comms from a Firewall point of view. However the Synology NAS has it’s own Firewall Configuration (even with Hard Wired LAN), it’s quit strict that way for obvious reasons :slightly_smiling_face:

I would suggest freeing up all Firewalls and see if you’re 4STREAM can see you Music Server. Then close them down and configure to suit.

Hope this helps, Kevin

P.S. FYI VE-Server is a Synology ds214play.

Good point from OP Mitchell bringing this up, I totally did not bring the update in relation to the NAS disappearing from My Music. My NAS supports DLNA/UPnP and SMB, is still visible from another streamer, but no longer for my S50Pro+.
Something definitively seems broken now.

Don’t know whether this is new, but if I play FLAC’s from a locally inserted USB stick, I sometimes have hick-ups.

@RvdOever @mitchel674

Welcome to the forum Rodney.

Been listening to NAS Server on Arylic MINI & PRO. Whilst it seems to work OK(ish) BUT the gap between tracks is longer than it used to be and sometimes it hangs up for me. So I need to push NEXT track to get some sound.

I have an S50+ so I will test that soon as well and report back.

Regards, Kevin

Kevin, it’s good that the 4stream app “sees” your NAS, but have you actually tried playing music from the app? My screen shots look just like your images, but when I try to play any music from the NAS through the app, they will not play. Any song I select just drops to the last song on the album with no music played.

This 4stream app is now broken and needs to be fixed.

1 Like


Yes it plays playlists on NAS ok(ish). However I experienced the problem you describe playing a playlist from Amazon Music on IOS app with iPad.

With my android phone the same playlist was fine.

Need to test more but totally agree there is something no quite right here.

Regards, Kevin

Oh by the way are you playing Albums NOT playlist ? Will check that side of things as I have only been launching playlists recently :slightly_smiling_face: