Up2Stream Pro V3 not responding

All of a sudden my Up2Stream Pro V3 doesn’t do anything anymore!
Only the WiFi LED is slowly blinking that’s it, it doesn’t respond to the remote either.
Any suggestions anyone?

Hi Walter,
Try this method by connecting by LAN cable, insert the cable and the white light should turn into fixed. If this happens then the device is connected, open the 4stream app and restore to the factory settings.
Wait for 1-2mins, when the white light blinking slow you can take off the LAN cable and try to pair the WIFI again.
Hopefully this works for you :crossed_fingers:

Hi Steve1

I tried the steps you mentioned but no luck. The device shows up in the app but it’s not responding. I think it’s save to say that the unit is dead.


Hi Walter,
Don’t give up yet, sometimes there is a bad connection between the main circuit board and the Linkplay board so with no power applied, gently prise the two boards apart and reinsert.
Then try restarting
Again :crossed_fingers:

The weird thing is I can connect to it via WiFi, do the whole setup, change the name of the device, start Internet radio via TuneIn but I get no sound and the WiFi LED keeps slowly blinking.

Hi Walter,
One thing I could suggest you try is trying another 5v power supply (if you have one), maybe the one you are using is not supplying enough current?
Worth a try?

Tried it,… still the same problem :frowning:

Hi Walter,
If you have tried the three aforementioned suggestions, then I’m afraid that’s pretty much all I can think of.
Maybe another forum member could think of something else you could try?
I’m thinking that maybe a power surge might have killed something internally in the unit.