Up2stream Mini V3 Wierd I2S output


I’ve been attempting to connect my Up2stream Mini V3 to a MA12070P amplifier. However, I’m experiencing issues with the I2S output. Instead of a clear signal, I’m encountering various types of noise, hum, and distortion.

I’ve taken some diagnostic steps, including connecting a 4-channel oscilloscope to the board. It appears that the BCKL (Bit Clock) and sample rate seem fine. However, I’m facing challenges with the actual data signal, which doesn’t seem to be making sense.

To further investigate, I connected the Mini V3 to an Analog Discovery 2 with a logic analyzer to decode the I2S signal. Unfortunately, the output from the analyzer mirrors the issues I’m experiencing when connected to the amplifier. I’ve experimented with different combinations, adjusting sample rates, formats, PLL clocks, and more, but I haven’t been able to get anything working. I can’t even decode the I2S signal in any format using the Analog Discovery 2.

Just to rule out the amplifier as the source of the problem, I tried connecting it to an adau1701, which worked perfectly fine with the amplifier. Additionally, I was able to read the I2S signal from the adau1701 using the Analog Discovery 2 without any issues.

I’ve attached two pictures that show the current settings on APCworkbench and the Waveforms logic analyzer for the I2S data signal. Yes, I’ve tried numerous combinations with different formats, sample rates, word lengths, and more. I’ve tested this with three different Mini V3 units, and the issue persists on all three.
In the picture a 4khz test tone is applied. However i get random square waves, and other wierd outputs depending on the format

Any insights or suggestions on how to resolve this would be greatly appreciated.

Hi Mathias,
The main problem with I2S that others have encountered on the forum is noise pickup from the wiring, try to keep the interconnect as short as possible, others have resorted to screening the cable to remove spurious noise pickup.

Hi Steve. Thanks for the quick reply :slight_smile:

As you can see on the waveforms screenshot I can’t get anything to even look like a sinewave. Rather a square wave. No smatter how short I make the wires that won’t change anything.

It’s like the volume is at 4000% :confused:
Ive tried bluetooth and USB. Same signal.
Ive tried turning down the volume on my phone/pc in the dsp software and in the 4stream app. Doesn’t make any difference.
As said I have 3 boards they all do the same.

Hi Mathias,
The I2S is a digital signal, so I wouldn’t expect to see any sine waves, square would be correct.
The fact that you have tried three different mini’s and the problem persists tells me that you have an issue with the compatibility with the amp you are using . Tell me more info about your amp, what is the Brand/manufacturer?

Hi Mathias, please do not change the I2S settings in the first tab, it might mess the system. Please do the Factory Reset on ACP tool and boot again. The default I2S output would have 2.8M BCLK, and 44.1K LRCLK.

The default MA12070P I2S format is Left Justified. Your ACP workbench screenshot shows I2S format selected

Hi Mathias,

I can confirm about what ernperkins1 said about the I2S input format of MA12070P boards. If you are familiar with UART, you can change the format to standard I2S. I suggest using an Arduino or an ESP32 to keep them boot up in that format. Take a look at the datasheet from Infineon.

Hi again. Thanks for all the answers. :wink:
Im well aware that I2S is digital. But the digital signal should represent the analog signal im sending it. Thats why i conected the analog discovery 2, as that can decode the I2S signal and draw the analog signal on my PC screen.

I have tried different combinations (if not all of them) with the ACP workbench app. Can the board not support left justified format?
I know the screenshot i supllied its in I2S mode.
I have tried left(MSB) Without any luck.
What is DSP Mode A and B? (I have tried them also, didn’t work.)