Up2Stream Mini & Ripple problem ?

I have had several builds where I combined Up2Stream Mini with an active speaker (amplifier built into the speaker). But my problem is that I often have ‘Ripple’ as a disturbing signal. Sometimes it is hardly hear able, and sometimes it suddenly increased.

This is what my build looks like. I integrated everything inside the speaker casing:

  • 230v AC > 5v DC converter - I used the official Apple iPhone USB charger as the AC/DC converter. It is small and easy to build into narrow spaces (and its ‘cleaner’ than a lot of step-down converters one buys online). The iPhone charger gets 230v AC from the incoming 230v AC power in the active speaker.
  • Up2Stream Mini - Powered by 5v DC coming from the Apple iPhone USB charger. For audio signal connected by a shielded audio cable: mini-jack on the Mini side, and connected to the audio in connector (RCA/Line-in) on the amplifier side.

See the drawing below.

How can I eliminate the Ripple disturbance?

I have a recording of the Ripple sound. If you want to hear it, let me know how I can send it over to you.

Is it a hum at mains frequency (50/60hz) or more like SMPS switching frequency?

Hi Ernst,
Well it wasn’t what I was expecting to hear, more like interference than ripple?
I would start by separating the components, give some space between them and see if the problem persists, even try maybe plugging the ‘Apple’ supply into a separate 230v outlet.
Can you try feeding the mini output into another amp? Eliminate that there is nothing wrong with it. Same with your powered speaker, feed another source into it?
Hope this helps!

Hi Steve,

Yeah, many people have different interpretations about ‘Ripple’, ‘Hum’ etc. That’s why I like to share sound files, so anyone can hear themselves. :wink:

I have tried different setups & tests like:

  • Change of audio source (iPhone instead of Up2Stream Mini) > Ripple gone.
  • Power to the Mini changed (clean battery instead of AC/DC converter) > Ripple still there.
  • Shielding the Mini in a small case with copper tape (like a cage of Faraday) > No effect, sometimes even louder ripple.
  • Also I heard that removing the jumper on the Mini board could help. But that’s not the case. Removing the jumper makes disturbances louder.

My feeling is that some part of the Mini is very sensitive, and picks something up.
Also, I am not sure if the setup (see picture in the top of this thread) needs more attention for grounding correctly.

Any advise welcome!

Hi Ernst,
Firstly re grounding, the fact that you tried powering with a battery and the problem persisted suggests that’s not the problem.
With a faraday cage over the unit and the issue somewhat worsened suggests to me that the problem is internal?
Have you tried a reset? If you haven’t, try that first, if the problem is still there I would PM Frank @zpl1025 and ask his advice.


Thanks Steve. I have tried resets > no change. Also I tried different cabling and I now only use properly shielded cabling for both the audio signal connection as well as for the USB power cable. But > still no change.

Yesterday, I changed the Mini for an Up2Stream Pro, using the same power supply and cables. Result > Ripple is gone! After that I used a S10 (which uses the same PCB inside I believe), result > also Ripple is gone!

This suggests that there is something wrong with the Mini.
I must admit that most Mini’s have no issues, some have the ‘Ripple issue’ immediately, and some have the ‘Ripple issue’ after a while.

In general it seems to me that the Up2Stream Mini is somehow sensitive to picking up this Ripple.
Therefor I ask myself:

  1. Can I solve this by adjusting something in my configuration, maybe extra grounding of the Mini PCB?
  2. Or anything else … ?

Let me know what you think.

Hi Ernst,

You have isolated the problem and proved beyond doubt where your noise was coming from. I don’t think any changes to your grounding will alter the outcome.

My only thought was to do a hard reset, but you say you have done this so I cannot offer any other suggestions or options that you could try.


I think so too that I have isolated the problem, being this Mini.

Concerning the hard reset, what I did was pressing reset 3 times, to reset the Mini.
I am not sure if this is the hard reset you refer too?

Hi Ernst,
In the app under speaker info, try ‘restore factory settings’.


Check, that’s the same type of reset that I do.
Or the other: 3x pressing reset button.

Hi Ernst,
I just reread your original post, are you using the mini in a mono configuration with just one active speaker?

Interesting you mention that Steve.

Yes, I use a Mini for each active speaker, as my build is a set of 2 active speakers combined as a Stereo set (configured in the 4Stream App). In the 4Stream App, one speaker is set as Left, the other as Right speaker.

Physically, per speaker there is only one channel connected between the Mini and the input to the Amp of the active speaker.

  • On the Mini side I use the Mini-Jack connector for Line Out; of its 3 connections, only 2 are used.
  • On the Amp side there is 2 connections for Audio In: Gnd & Left or Right

Hi Ernst,
I’m wondering if the problem is only affecting one channel of the noisy mini? Do you think that it might be worth swapping the two mini’s and see if the issue persists using the other channel?


Good suggestion Steve.

I have 6 Mini’s in my workshop. Yesterday I tested them all, and they all give the same level of Ripple. But this was all on the same channel, being Left.
I haven’t switched the channel to hear if that makes a difference. So I will check that and come back.

Also I wonder …
Could it be an issue that the Mini has a Line-OUT with 3 connections, of which only 2 are used?

Re your query ‘Line-OUT with 3 connections, of which only 2 are used?’ Have you tried connecting to the line out JST connection?


At the moment I only use the Mini-jack as Line-OUT, because this is the only way I can use an audio cable that is shielded.

The JST connector I used in the past, but wasn’t that happy with because this was unshielded.

For testing I can of course try it again to check what it does to the Ripple.
I will do that.


Worth a try, a few mm of unshielded cable shouldn’t be an issue.

I see that you tried your luck with the issue on diyAudio too :slightly_smiling_face:

You guys are very professional with the electronics, I’m more likely familiar with software :slight_smile:

I have no clear idea for the issue. Anyway, one point might help to debug, the 3.5mm jack might not connect the detecting pin to GND, so the 4 segments plug might have issue.

Hi Frank, thanks for hopping in on the topic!

Do you mean that the 3.5mm jack has no proper connection to GND?
And that the 4-pin connector might solve that?

Or do you mean something else?