Up2Stream I2S distorted right channel only via network

I already discussed this issue in Tutorial: Connect Mini/Pro to other I2S DACs - #35 by zpl1025, but we found no solution. Now I want to ask a wider audience:

I have connected the I2S output of a Up2Stream to a ADAU1701 DSP. If I stream audio over the WiFi or Ethernet, only the right channel creates heavy distortion. This issue doesn’t appear if I stream audio over bluetooth, USB or analog input. If I switch the LRCLK the distortion comes only from the left channel.

Also the automatic voice, which tells me that the WiFi connection is connected, is distorted. I think it’s related to the Linkplay board. I tried another Up2Stream but get the same result.

HI,
I have had no distortion using two different I2S Dacs or using the SPDIF as Coax with the Mini V3.
I suspect that your wiring may have a break in the harness causing issues especially if the wiring is multi strand rather than solid Core. Alternatively it might be a power issue.
Are you feeding power in Via USB only as the Mini may have current issues feeding an attached DAC. IF so you need to supply 1A or above at 5v to the separate power connector (no need of the usb connection for power)

I checked the cable four times, cut it, soldered it new. Always the same problem. And how it could be a cable problem if it only appears with audio via WiFi or Ethernet? Bluetooth over I2S works fine. Also if I use 3,5mm jack connector. If it would be a cable issue, also this signal should be distorted. And how can It switch from left to right depending the LRCLK setting? If I use the Mono mode in the App and use only left channel it works fine. If I use Mono mode for right channel, distorted signal appears on both speakers.

If I use the SPDIF connector also it works fine, but I think it uses the additional extra pin.

I use an exclusive power connection with 5V which can deliver up to 5A via the separate power connector.

Hi,
Can you make it clearer what works audibly?
Just on its own without the additional Dac is it sounding Ok with no Channel problems with the 3.5mm output?

You said SPDIF was working, is this an optical or coaxial? Are you feeding it to a different Dac?

Do both these outputs show no interference on the L/R channels?

If the interference is only shown with the I2S there is a possibility that the added DAC has a problem especially since you say that it’s the same problem with two Up2Stream units.

I just ran breadboard pin wires between the harness connector to breadboard and then out to Dac plus an RCA connector for SPDIF and didn’t need to change any settings it worked straight away for two different dacs for I2S and a two other dacs for SPDIF.

Ok, sorry, my English is not the best. The I2S output is connected to the Wondom Jab5 (with ADAU1701 onboard). The Jab5 is configured as slave. Now I tried following inputs:

  • WiFi input and I2S output: has distortion on right channel
  • Ethernet input and I2S output: has distortion on right channel
  • Bluetooth input and I2S output: has no distortion
  • 3.5mm Jack analog input and I2S output: has no distortion

The I2S has only distortion if audio is streamed over the Linkplay module - as far as I understood the architecture.

Then I removed the I2S and replace it with the arylic SPDIF/Coax output broad and connect it to my HiFi Amplifier (Technics SU-G700) via Coaxial. In this case everything works fine.

I don‘t have an other DAC with I2S to test. In my opinion nothing is broken. I think it‘s a communication problem. But only with the I2S stream from the Linkplay module. What is the difference between the I2S data stream from Linkplay and the Bluetooth data stream from the Up2Stream board (Bitlength, clock, etc)?

Hi,
I think your best option is to buy one of the little low cost PCM5102 from Amazon or ebay. Wire it in an see if you have the same problem. That will tell you if your other dac has a problem or not.

The Linkplay will be sending an I2S signal to the onboard dac (the one feeding the amp to the 3.5mm output). That should be the same I2S signal being sent to your DAC.

I find it difficult to understand why the boards own Dac works with the I2S and yours doesn’t, it seems a very strange fault especially when you say the fault is on both boards.

Where does your Dac get its power from? Same supply and Ground as the Up2Stream?

I haven’t downloaded the software for the ACP Workbench; maybe try resetting back to its original settings if you’ve been tweaking the ACP. The I2S was plug and play for me without any changes.

This doc covers the A28 LinkPlay module; the A31 just has a better processor. this should give a better understanding of the I2S.
LinkPlay Wireless Smart Audio Module (A28) User Manual | Manualzz

I agree. I need to test it with an other DAC to get better insight on which part causes the problem. I ordered the PCM5102 board.