Up2stream amp v2 failure

Hello all, I have an up2stream board that went belly up, the stamp on the board has up2stream AMP V1.1
and it was running firmware 4.6.415145.24 build date 20220427

I was using it with some 8 ohm in wall speakers that have not caused issues in the past and based on testing they are fine.
I was playing it at normal volumes for about 2 hours one evening and then paused it.
The next day it would not show itself on the network so I went to investigate and found it to be dead.
Ive tested the power supply and its just fine, but when I plug it in to that unit it immediately shuts down and shows 0 volts. Ive tried other power supplies on it and they do the same thing.
I looked for blown components in the power supply path but did not find anything so far.

Im beguining to suspect the amp chip itself is blown but have not rtroubleshot that yet.

Has anybody seen this issue and know how to deal with it?



1 Like

OOPS, I broke it, :unamused: while trying to get the heat sink off I applied too much force and ripped the chip right off the board so this one is toast. at any rate, its amazing how much power this little chip can deliver and still sound decent. In retrospect I should have tried to heat the chip with a heat gun and pull it off that way rather than trying to get the heat sink off. I tore all the traces on the board and its not worth trying to fix at this point. don’t try removing the heat sink. its stuck on really well.

1 Like

But whyyyy?.. :slight_smile:

1 Like

At least he has a spare Linkplay board :crazy_face:

1 Like