Up2Stream 2.1 not working in ACP workbench

Hi

I’ve got a bit of a problem with 2x Up2Stream 2.1 Amp boards when plugged into my laptop to configure in ACP Workbench. I configured one a little while ago so that the left and right outputs are in mono mode, with the left EQ doing mid frequencies and the Right doing high frequencies. This is so I can use it in a single 3way PA speaker. That one connected and configured just fine, so I saved the config file of it as to upload it to the other one I was making. But when I went to do it to another one, the board didn’t bring up all the EQ for left, right, sub plus a load of other bits. Tried disconnecting and reconnecting but still nothing. It also doesn’t let my keep my laptop connected while I switch to WiFi, the laptop instantly says disconnected (doesn’t do this on the other good one). I’ve also tried this on a 3rd board I had and still does the same thing. Yet everytime I connect to the first one it still brings up all the relevant settings. Hopefully the pictures I have attached will show more what I’m on about. But basically I need to access effects 0 but there’s nothing in there when I connect to the 2 faulty ones. Have also done several factory resets and updated the firmware. Another thing I cant seem to see on the faulty ones is any of the source input levels nor any of the PIN KEY, PIN SPDIF, PIN GPIO1, OUTPUT MODE settings. Anyone know what I might be doing wrong or have I just got 2 fault modules?

Ryan

Another thing I have just noticed is that the working one says its using between 35-47MCPS/ 320 whereas the faulty one have nothing, even with music playing…

after a bit more investigation it turns out i have been an idiot…when clicking the udate firmware arrow in the 4STREAM app it put a wierd firmware on there but wouldnt let me upgradeit to a better version. so have had to do a manual update and it is now working.

@Ryan_Kelly

You certainly haven’t been an idiot :slight_smile:

It helps to explain a technical problem on a forum so that you have to think about the steps you did. Although there were no suggestions from users I am sure that sharing it helped with the thought process of finding the solution :ok_hand:

I haven’t used the ACP Workbench yet but I plan to. When I do at least I can now search on the forum and see other peoples experience (like yourself) when I do :+1:

Regards, Kevin

1 Like