S50 Pro+ play back USB

Hi there i have a S50 Pro+ which i have put some FLAC files on a USB stick and towards the end of the song the song jumps or skips a little every time on every song.
Anyone know of this problem and maybe a fix have firmware vers 4.6.415145.35

Thanks lots

2 Likes

Hi,
I’ve the same problem with MP3 or other format on USB stick.
Any Idea ?
it seems also that only 2049 files are visible even if there is more on the Key. I assume it’s linked to the format shall I use NTFS or FAT32 or exFat or ?
Thanks for pour feedback

There is a limit to the number of files that the device can handle plugged into the USB, The device has a 1000 song limit and also cant deal with very large USB drives even with small files loaded.
This is to do with the processing power of the chip onboard and so the software has a file limit set.
I couldn’t get a USB 125GB to work but the 16,8,4gb all worked ok.

The Device is also a very good at accessing DNLA, so if your files are on a Music Server or your Laptop/PC with media access rights opened, the Arylic can pull the music off the ethernet.

Hi C3pored,

Thanks for your quick reply !

I’ve made additional test this night. I’m using a 256Go USB key (FAT32).
The S50 Pro+ device is able to read it except the limitation of the 2049 files as already mentioned (not far away for 2exp11 = 2048), that already a lot of files ;-).

I’ve also connected this key to the USB PORT of my internet BOX to use it as a NAS.
All files are visible using 4stream app.

The only issue I’ve is that I cannot play the files directly by cliking on.

I found a workaround by adding them to a playlist or associating an album to a favorite (1 to 9).
When it is playing I can use the “play next” if I want to jump to different artists/songs or a new favorite to jump to a new album.
Any advice to make it a bit more simple ?

Thanks in advance !
Regards

Hi,
Tried seeing what my router did but usb access not possible so I can’t check what you are observing.

I wrote about the same problem weeks ago, the problem is not only with a usb key but also streaming music from the NAS. It can’t be a problem related to the number of songs: it worked perfectly before the last upgrade, it was not gapless form a song and the following one, but the sound was ok till the very last second of each song. I do hope they will deliver a new version of the firmware fixing this problem.

Thanks for the info yes I am still having this problem as well :pleading_face: hope they come out with another software update to fix this bug soon, or I might have to buy a bluesound node.

Hi all,
if someone from Arylic reads here can give us an indicative date of when the new firmware update will be released?
I bought the S50 PRO+ for over two months to use it as a network streamer but due to this annoying bug it is unusable.
I only use it to listen to web radios but I would like to do something more with it…

2 Likes

Yes a agree this bug needs to be fixed.

1 Like

Agree.I have the same problem. When will be fixed? The product is not usable like this.

Hi all,
I added a NAS to my home system and connected it to the S50 via wi-fi.
Then I converted all my CDs to FLAC and copied them to the NAS disk.
Playing songs, with my great surprise I saw that the the jumping and skips was gone !! It only occurs in very rare situations when, for example, I handle a lot with the app.
The converted CDs are over 300 so it was not a problem of quantity.
Apparently it’s just a USB reading problem.
We always wait for the firmware update but using a NAS I can say that the device works fine…