S10 Bluetooth bad audio quality on Windows 11 "Handsfree Telephony"


Since the last S10 update (4.6.415145.25) and/or some Windows 11 update, every time I reboot my PC, the S10 will always connect using Bluetooth “Handsfree Telephony”/audio+mic, instead of only “audio”.
This is a problem because :

  1. the sound quality is horrible, sounds like a 32kbs mono stream
  2. the PC master volume no longer controls the BT music volume

To fix this, everytime, I need to disconnect the BT device, open Bluetooth settings → More devices and printer settings → double-clic the S10 device in the list → uncheck “Handsfree Telephony” in the Services tab, then reconnect.

I’ve found no setting in the 4STREAM app to disable Handsfree Telephony.

Is there a way to permanently disable Handsfree Telephony on the S10 ? Or any other way to fix this?