Repacked firmware update for A31 module with WEB UI fixes.

Hi, for the A31 firmware, the latest version is 4.6.415145. And there’re some minor issues in the firmware and not updated for a while. And the sad news is we can’t get a building release from the module vendor. But we tried to extract and repack the firmware image to fix some of them. And we have no ability to change the binary and only updated the WEB UI related resources. So, if you’re happy with the WEB UI, it should be a good choice.


1, added version info for js to avoid old version used.
2, by default disabled the background OTA, and could enable it in Settings
3, fixed a login state issue in radio
Changes (WEB UI only):
1, fixed the EQ display issue, it can’t scroll down
2, will not request for login by default
3, personal radio user could choose to resend the activation mail
4, fixed an issue when set device name with some special characters

1 Like

I upgradet that - and I regret it…
WEB UI let me only ajust bass and treble now
All other things are greyed out.
I tried some factory settings without effort

Please let me go back… :expressionless:

Thanks for the try :sweat_smile:

Anyway, could you tell the board model? better give the Project ID and Firmware Version read in the settings page. I’ll check what’s going on

I’m back at 4.6.415145 again. WEB UI working as before. I found it here:

Tested with firmwares

btw… still would be very very happy to have an option to deactivate the silent ota’s.
I know about blocking the server in my router - but my “customers” (family, friends) don`t.
And they may use it in different networks without the blacklisting.
The latest ota-firmware is setting the virtual bass to “ON” with 30% after each restart.
Thats really too much bass - using 5% only in my setting with normally OFF

Cheers PP

Strange, I’m using v44 mcu firmware, and after ugpraded, the audio settings is working fine. Could you try to clear the browser cache? Some js files are updated but filename not changed, so browser is using the cached one. I guess this is the reason, and I’ll rename the updated js files with version later.

I’ve updated a version and by default turned off the auto upgrade.

I can give a first answer:
You were right. After clearing cache the WEB UI is working.
I’m now on mcu version 33 with your linkplay 4.6.415151 version.
Now testing the silent ota behavior (leaving it idle and wait…)

It has updated again to mcu ver. 44 in idle mode. :confused:

Sorry… I confused you I think
The problem with the audio settings (in my case virtual bass) has nothing to do with your Linkplay A31 update. It is a problem in the mcu ver. 44