Qobuz not connecting on up2stream HD DAC

I just bought a up2stream HD DAC. Before I already used 2minis, Prov3 and Ieast M30. These later are working fine with Qobuz via the 4stream app, or IEast app or IEastPlay app.
My HD DAC is connected via LAN, I can play stations using tunein or music using Foobar2000, but my Qobuz account seems to disappear in the big vaccum… I can not play any content from the service. I tried to logout, nothing happens i.e it does as if it’s always connected. I erased all data from my phone, tried to log in again it states ‘login failed’ but then when I close and reopen the app and select Qobuz as music source, I only can see the music proposed by the site, my favorites are empty as well as my playlists and the logout menu is again available…!
When I select another device like a mini or prov3 it’s working fine!!!
Anyone having the same issue?

I’ve sent a lot of details to Arylic, in reply to their questions, with a lot of detailed screen shots, with Mac addresses, FW versions etc… and did tests with a MiniV4(4.6415145.34) which works fine with Qobuz, as well as testing a multiroom config with the miniv4 as MASTER and the HD Dac as slave, Both are streaming the Qobuz music content, but in 44.1khz/16bits (capability of the MiniV4). I noticed a discrepancy in the MAC address of the HD Dac, it’s labelled B8:13:32F3:.66.90 and the one recognized by the router is 00:e0:70:00:0b:52. More over, using a different network set up I could see that the miniV4 as well as my up 2 stream prov3 are identified as LinkSprites products, where the HD DAC shows DH Technologies… and is not really stable.
Their answer:… ’ I checked your all reply, then the HD DAC Board does not support web control ’

I don’t care for the time being about the web control, although the HD DAC is a kind of black box without further control features, (like manual IP settings etc) but more importantly I bought this device to enable Qobuz HD music streaming!!!