Pro v3 firmware upgrade fails

I had 3 pros that was going to return but decided to utilize them after all. Now I have hard time trying to commission them. Two first units are struggling with fw update and they won’t play synced with my arylic amps without updating.

Update with wifi fails instantly. Update with lan fails at 33% with just “unknown error” text.
First unit gave this error 3 times but then after reboot was updated to .29 anyway. Second unit doesn’t want to update even after 5 tries.

Frustrated by this I purchased ACPWorckbench as it was advertised with FW update capabilites but… you did not mention one cannot find the firmware update binaries from anywhere? Is there really no git repo or any place to get these? I need to request them via email?? And do that every time the update of some new FW version fails??

@zpl1025 @Joy

I find there are reasonable amount of people on the forum that would like to revert to old firmware as @WillMackey.

I would seem to me that it would be a good idea to populate the web page Firmware |. However if the problem is that devices will auto update it would be good to put up some message on this page to explain the situation and then link from the forum.

I think it’s an issue that needs some form of “standard” explantion to avoid mixed messages on the forum.

Kind Regards, Kevin

Hi Will,
For the PROv3 board which failed to upgrade, I’m not sure why it failed, you can try to reset factory in App and try again. If still no luck, and since you have the ACP tool, I can send you the firmware directly and which would be downlaod to board via the tool. Please send me a mail frank@arylic.com

Hi Kevin,
Thanks for the suggestion, will try to maintain the firmware changelog in the firmware page. It would make some sense. But it’s not good to give the firmware file directly, because the device might not work when downloaded with wrong firmware. And I think let the device itself to detect and upgrade, would be more safer.

Hi,
Yeah I tried the factory reset but it didn’t help. Thanks, got the FW via email.
But there’s more to this:
I tried updating the second device at least 10 times, always got the ‘Unknown error’ and the device rebooted automatically. I also power cycled it again several times and always gave it a good amount of time after update try and also fully restarted the mobile app to make sure it’s showing the refreshed info. No go, but then I left the device powered over night and in the morning came to see and the app showed it had updated itself :man_shrugging:.

So it seems it’s not (at least always) really failing but still for some reason shows the error and then after some random amount of time it reports having been updated. Again, the first device reported the error during the last update try, but instantly after reboot reported it had updated fine whereas this second device reported updated status after some much longer period.

I still have the 3rd device waiting for a successful update. Is there some specific steps you’d like me to try to get some more info about this as the current report is most likely not that helpful to you?

About downloading wrong firmware:
True that someone could brick the device by downloading wrong FW, but then again I could now download this ProV3 FW to my Amp V4 if I’d be really careless and I think this possibility is always there, with several consumer devices and even with PC BIOS/UEFI updates etc. (although they tend to have a validity check, maybe FW updater could do that too, at least some simple header info).

@zpl1025
I think there’s still some confusion about what the problem is. Here’s a video about updating freshly unboxed Pro V3. Maybe it clarifies.

This is the process I’ve repeated 10 times for the second unit and always end up failing but then after it just sat powered overnight, it suddenly showed that the FW had updated. It’s clearly a bug in the update process flow so that it

  1. shows and error once the update has completed
  2. does not report having the new firmware instantly after reboot but instead needs some ??? amount of time to really complete the update, all this without informing the user at all.

I’m not sure for the reason, but I guess it’s a network issue, so the firmware is not downloaded correctly.
Btw, will consider to place the firmwares which could be used to upgrade via network, the device will check the validity in this method. So user have the same issue would have a choice to upgrade it directly without internet.

I don’t agree with the network theory. This device in the video reported having been updated when I left it sitting there for 1 hour. Could have filmed it but would have been quite boring video. Did not retry the update. Did not touch it at all and then it (like the 2 others) miraculously report having been updated. Like like update process would continue running after the first reboot and that it would take some time.

My Pro v3 behaves exactly the same when trying to update the firmware. The update reaches 33% and fails. WiFi or LAN doesn’t matter. Could it be a server side issue?

@Irek did you try just leaving it on after the error message? Try that and check after one hour again (close 4stream app completely, reopen and check fw version again). In my case they do actually update even with the error message but there’s some delay before they report the new version.

@WillMackey
It’s been on for a few hours now, but no change so far. I will leave it overnight. I hope it doesn’t turn into a pumpkin at midnight :rofl:

:man_shrugging: Well any activity in general is progress, right?
All 3 units I updated eventually reported the new FW but the delay varied. The first one did it after just few mins (it was the 3rd update try tho). Second took overnight so no idea really how many hours but I know it was matter of hours as I did check it after one hour since the last update try and it was showing the old version still. The third one took ~45 mins (that’s when I returned to check it after that video).

There was no miracle at night. The firmware has not been updated.

Hi,
I hade what sounds like the same problem, in my case it was do to my router and my wifi extender had the same SSID (same Service Set IDentifier so that my portable device automatically can choose the strongest) and password.

First when I turn of my wifi extender my Arylic device manage to update the firmware.

Maybe the Arylic amp gets confused!

Yogi

I tried both WiFi and LAN. WiFi failed instantly and LAN did what’s shown on the video.

I did it! How?
At first I noticed that for some reason, with the LAN cable connected, the board continues to work via WiFi. It seemed strange to me and I began to understand. disconnected WiFi antenna and rebooted. The board showed a signal level of only 12%, but still WiFi. Then I did a factory reset and rebooted the board again. After that, miraculously, the board reported that an Ethernet connection was established! After that, I launched the update and was very happy when I saw 34% on the progress bar!

After some time, the update was completed successfully.

Tomorrow I will check whether the parameters changed in ACPWorkbench are saved after the update.

Happy New Year! Arilyc! :partying_face: :clinking_glasses:

1 Like

Nice one @Irek.

In most Home Devices that have a Wireless Card & Ethernet Port there is usually some form of user interface that allows you to select WiFi or Physical LAN Port. It seems on the Arylic/Linkplay Devices this is done (in the background) when you configure the device from factory settings :thinking:

It even doesn’t seem possible in the recent Web Management Interface ! I haven’t ever experienced Firmware Upgrade problems with my Pro v3. However maybe it is because I plugged in the LAN cable before switching it on for the first time ?

As I expected, after the update, ACPWorkbench stopped saving parameters :frowning:

I tried this in different ways and it didn’t seem to matter:

  1. With the first unit I plugged the ethernet cable in before the first bootup.
  2. Same with the second unit and also tested the WiFi after the cable had failed.
  3. With the third unit I plugged the cable in in the middle of first ever bootup, like seen in the video.

@WillMackey
Yes that’s right. Your video shows that your connection was Ethernet. But my board was on for two days trying to update. And I just wanted to say that this also happens and you need to pay attention to the type of connection. Surely someone will also bang his head against this wall. So let him know all the ways :slight_smile: