No "Home Music Share" in Android app

Today i installed the Up2Stream Amp V4 and i got most of the audio sources (bluetooth, amazon music, internet radio,…) to work.

But i’ve also a NAS with a twonky dlna server in my network, but i can’t play any music from the NAS because i have no menu item “Home Music Share” in “My Music”.

I tested the twonky server with another dlna player (BubbleUPnP) and the server works fine.

Firmware is 4.6.328252.29
App version is

Hi @patrickrhrl,

Welcome to the forum, I can assure you that it is a friendly and supportive place.

I think your situation is a strange one :thinking:

Q. I tested the twonky server with another dlna player (BubbleUPnP) and the server works fine.
A. The DLNA Sever seems to be broadcasting OK for me too :+1:

Configuration Questions.

Is your Up2Stream Amp V4 on LAN Physical Cable or WLAN WiFi ?

So I would in the meantime :-

  • Power Off Arylic
  • Power Off NAS
  • Reboot Router
  • Power On NAS
  • Power On Arylic

Everything still the same ?

Yes then
Download this tool from Play Store and see what devices appear on your network.

Post a screenshot of the results of a LAN scan with this APP.

Kind Regards, Kevin

Hello Kevin,

thank you very much for your fast response!

The Amp V4 is connected via WLAN WiFi. Does it make a difference for the Amp V4 how (cable or wifi) it’s connected the network?

I restarted the devices according to your instruction, but nothing changed.

Here the App’s scan result:

Kind regards Patrick


One approach could be to create another Music Server on the Network to check it is not alone a problem with the Twonky. This can be done easily with a Windows Computer, Even a Media Server App on an Android Phone.

Note: I think with this problem the Arylic Hardware Device is not involved. I think it is problem 4STREAM APP <> NAS Media Server. However you can’t try to do anything in the APP unless the Arylic Hardware is present.


Hi Kevin,

i just tried it with another dlna server and it also doesn’t work.

so it doesn’t seem to be an issue with the NAS.

when does the hardware/app scan for dlna server?

kr Patrick

OK Patrick,

  • The UPNP Tool we used on the Android Phone shows that the Discovery of the TWONKY Server is working (mDNS). This rules out Router or Firewall Problem for me

  • I assume the scan on the Arylic Device takes place when you hit “MyMusic” on the app.

I have run out of ideas without getting into detailed Ethernet Packet Sniffing. I am not sure how the process works myself so that would be time consuming.

Maybe try to uninstall and install the 4STREAM APP. What Version is installed ? Do you have a friend with an Android Phone ? Maybe try another phone.

If none of this works I guess it would point to something in the APP as the problem.

Regards, Kevin

Hi Kevin,

i would also rule out router/firewall/network problems, because other devices are working like a charme with the twonky or other dlna servers.

I think this will be the next step, i will sniff the network traffic with wireshark to see if i can see any upnp discovery packets.

I already tried with another Phone and there it also didn’t work. So i don’t think it’s an installation issue. You can see the app and AMPV4 firmware version in my first post.

If i will have any findings i will post it here, perhaps it can help somebody else in the future.

I will also try to contact the arylic support on another channel, perhaps they have a solution.

Thanks for your help! Kr Patrick

1 Like


Wireshark would be my next move :+1: