New 4stream App and Firmware Upgrade 4.6.328252

Great. Thx

how to return to the official firmware ??? I now have a beta firmware that is not updated. How can I get from the beta firmware to the official one? how to install 4.6.328252 if devices already have beta-ver: 4.6.9724.26 ???

I have 4 devices A50, AMP-2.1, Up2stream Pro V3. I wanted to buy a few more A50 +. But for a long time I can return it to the beta firmware on the official one ??? How can I get back to the official firmware ??? I now have a beta firmware that is not updated. How can I get from the beta firmware to the official one? how to install 4.6.328252 if devices already have 4.6.9724.26 ??? Until I return my devices to official firmware, I will not buy your new devices. Please help with this question !!!

Compared with older versions, i noticed that it takes too much time (1 min & 34 sec) to go from power off state to “Connecting to your Wi-Fi network” announcement.
Does any other friend have the kindness to count this time on his own device with this new firmware?

@Pepelitsa I’ll time it but do you know how it took before ? Also what device are you using ? Regards Kevin

Now we only have ACPWorkbench to do the detailed equalization.

May consider in the future.

Yes, that is available.

You can follow the instructions for update:

  1. Replace to your device IP, you can find device IP in settings>speaker info>device IP

  2. Put the URL to your browser

  3. Back to your app to perform the update

Sep 14 update:


This article may help you.

Ok Joy… I’ll think about…
BTW for Firmware…should I Stay with Beta Test One or I’ve to change and if yes in wich mode can I update 'cause OTA don’t change nothing.

Manu thanks in Advance…


All ok!
all devices updated from beta-ver 4.6.97… to original firmware 4.6.32…

  1. need ip-adress you devices.
    my devices:

for every devices need: (example):

  1. open link " "

  2. open 4Steam.

  3. update info:

1 Like

After the firmware and app upgrade none of my devices that previously reinstated their play in sync mode after being powered up again now refuse to do so…
Anyone for suggestions (Yes I tried even a full reset and re-installl :frowning: )
Joep from the Netherlands

You should post this in the first post, and over on the Beta thread.

Thanks, I update in the article.

FYI My A50+ takes 35 seconds from power on to WiFi connected…

1 Like

I have the same problem. After updating to version 4.6.32, I cannot connect any devices in synchronize mode. Have you solved this problem?

I further investigated, and found that when you connect using ethernet instead of wifi, the wifi-id disappears from the speaker-properties and the auto-reconnect stops
It seems that a too tight link between wifi id and playgroup causes this
I reported this to Joy from Arylic
Hope it gets solved soon :crossed_fingers:

Thanks for the clue, will check it

Meanwhile tested in two different installations.
It seems to be so that when the WIFI AP and the router are one and the same device, setting up and restarting synchronized equipment is no problem even when part of the devices are on wifi and others are on wired ethernet.
When some of the devices are on WIFI AP’s separate from the router used for DHCP in the installation and others are ethernet-wired to this router is when trouble seems to start.
It starts feeling like somewhere down in the ethernet-stack handling things are going haywire in the separate AP setup?

In the 2nd installing, the device connected to WiFi AP and to the switches, got the same IP segment?
Actually in the office, we used one router without WiFi, one switch and 2 AP to extend the wireless network. I think this is the same with your 2nd config, but it’s ok when we test the multi room function.