Mini > Wi-Fi Setup Timeout

I have a nasty problem with three Up2Stream Mini’s. One I have here in my workshop, and two are in a speaker set delivered to my customer.
The problem occured with Mini’s I had already in use, and connected to the Wi-Fi network. So this is not about a fail at first time use, this happened after using the Mini’s for a month. These are Mini’s V4, produced 2022-02-22

This is what happened
After working fine for a month or so, suddenly all three modules lost connection to the WiFi network, and are not able to reconnect anymore. This is what the 4Stream App shows:

What I have tried (A) > BLE WiFi

  1. Factory reset the modules, by pressing the reset button on the board, 3 times.
  2. When the LED blinks slowly, start the 4Stream App and add the module.
  3. In this step, the 4Stream App does recognize the module in Device Setup, as one that can be installed. So I select it and press ‘Setup this device’ to start the installation.
  4. Next I select the WiFi network, add the password, and press ‘Next’.
  5. After 10 seconds the LED stops blinking and goes to solid. Though the 4Stream App continues to try to connect the Mini to the WiFi network. Then after a minute or so, the screen changes and shows ‘Wi-Fi Setup Timeout’ like in the screenshot above.

What I have tried (B) > AP

  1. Factory reset the modules, by pressing the reset button on the board, 3 times.
  2. When the LED blinks slowly, open WiFi settings on my iPhone. In the list the Mini shows, and I can select it. But I immediately get the message ‘Connecting with network ‘SoundSystem’ not possible’.
  3. At some moment, the LED stops blinking and goes to solid. Then the ‘SoundSystem’ also disappears from the WiFi networks ist.

I have repeatedly tried to solve this, but I get the same error all the time. Very annoyingly, now my customer is not happy with this problem.

I did read the threads on the Arylic forum, including the suggestions by Joy. But none worked, or helped me find a solution.

My question …

  • What can I do?
  • Is there anyway to solve this and get the modules Wi-Fi connected again?

@zpl1025 @Joy @SimonB @NWT.Stuff @Dmitry

Hi Ernst,
So the three minis are on two separate networks, but showing the same connection issue?
I guess you have rebooted the modems?


@Steve1 and all interested

Here’s an update on the above. Solution has been found.

In total I had 3 Mini’s which seemed to have the same issue. But I found out, they had different causes.

(A) 2 Mini’s in a speaker set at a distance
These Mini’s were at quite far distance, so not that easy to go and check. Therefor, I decided to instruct the user following:

  1. Unplug the active speakers (Mini’s inside here) from the power socket.
  2. Power down the Router & WiFi, and keep it unplugged for a minute.
  3. Power up the Router & WiFi again, wait for 5 minutes and check if the Router & WiFi were on again and working normally.
  4. Last, to power up the speakers one by one. And if necessary re-connect the speakers/Mini’s to the WiFi network via 4Stream App.

Result: everything worked again.

Findings: With this one I suspect that something happened on his electrical system, maybe a power peak. But at least it caused the Mini’s to loose connection, but also loose the WiFi network settings. In the end it appeared simple to re-establish the normal working condition.

(B) My own Mini
The other issue was with my own Mini. With the help of @zpl1025 (Frank) I found out there was a strange character in the SSID name. So I changed the SSID name through UART to a different name, and checked if there was a strange character. There wasn’t. Then I tested to connect the Mini to my WiFi network in the normal way, via 4Stream App.

Result: everything worked fine and at once. Perfect!

Findings: This was a great learning case. I learned that when the LED changes from blinking to solid, I can trust it has connected to the network. But I also learned that a strange character in the SSID can create that the App will not recognize the Mini as a device.