GoControl Not connecting to BP50

My Andriod 14 phone can connect through bluetooth to the BP50. However, using the GoControl App, it’s stuck on Select Device (Loading). 40 minutes+ and nothing has changed. I’m logged into GoControl and emailed them about the issue; no response.
Any suggestions?

1 Like

yeah this one is super annoying

the problem is that the BP50 has two BT modes… one is when you’re just connecting a phone to stream mp3 via BT…

you cannot get Go Control to work while in this mode.

i think it has to be in some other mode

also i found that it works best on a new fast phone… the app just sucks on anything slower

1 Like

Same thing for me, the app doesn’t work and they don’t answer. Maybe it is linked with the firmware ? My BP50 is from october 2023 and I can’t load a newer version without the app…
I’m pretty much disapointed with this product.

I tried what you say and it doesn’t work either…

I finally got it to work. With the your phone connected to the BP50 through Bluetooth, uninstall GoControl. Then reinstall it. Launch GoControl, give it full access, and it will find the BP50.

1 Like

Hi all,
I had the same issue and solved it by connecting the BP50 through Bluetooth and by activating gps on the phone before searching devices within the app.
I had the same problem with a pair of TWS BT in-ear and still don’t undestrand why I have to enable gps but it worked.

Thanks a lot. I used both tips and it works !