Giving up with 2.1 amp

Sorry Arylic and ACP don’t work. After connecting to ACP through USB there is no output on toslink and after making EQ and flashing, amplifier makes big loud noise that can destruct speakers.

Sorry, but it seems you won’t get very much help here for the diy products anymore .

Tried different USB cables?
I’m using my samsung phone cable which is working fine.

The newer firmwares getting worse with every update…

Do a factory reset, flash the older firmware you can download here ( 4.6.415145.35 )
and after that block access to in your router.

That’s working for me.

The USB audio input has some issue with SPDIF output, so it’s indeed not working as you’ve seen.

I’ll try older firmware. I would like not use wifi because board to board delay is then much lower (1-2msec vs 20msec on toslink).

Question - when you make changes in EQ should you hear the difference imediately or what you have to do?

Yes you should hear the filter changes in realtime.

After connecting USB there is silence. Anyone tried?

ok seems work now but sound is strange - voice going from L to R. I turned on bass boost:

When you connect to USB it is your PC audio device, turn on some music on your computer or switch back to other input.

Made decision - returning. Impredictible, loud noises without reason.