Firmware Upgrade 4.2.9326.24

I understand what you just said, but I’ve noticed that it takes a long time to get updates to the devices. Anyway I’ll have to wait for the update, thank you for your response and support.

New API commands are also available in HTTP api or only UART?

Can you please give us a hint on now to send commands to the device?

Executed command:
Always getting result:

What is the correct syntax?

ok sure, i’ll prepare the documents in one place and share it

Hi, do you have the documents to share with us?

This is a documents prepared before, and you can refer to it at first:

We already got this from you, but it’s incomplete, because it does not cover the complete commands set as described in api-info-UART.xlsx.

Please give us information on how to syntax the commands from api-info-UART.xlsx. because the result is always AXX+UNKNOWN.

You need to send MCU+PAS+RAKOIT:{message:param}&, for example to query current version, you need to send MCU+PAS+RAKOIT:VER&.
btw, you could test with the UART tool in the first post

In the first post there’s no tool, just a list with commands.

I tried MCU+PAS+RAKOIT:VER& and the result is AXX+UNKNOWN. Firmware is 4.6.9724. Tried on Up2Stream_AMP3, A50, S50Pro.

I know I send commands in correct format to port 8899 because MCU+VOL+GET returns AXX+VOL+017 which is true (volume is indeed 17). Also MCU+PLM+GET returns AXX+PLM+010. Similarly MCU+DEV+GET returns AXX+DEV+INFmySSID;release;Up2Stream;;0;0;0& etc…

It seems PAS commands don’t work.

sorry, I thought the link is the tool :rofl:
please use this

Thank you now it works, but only with Up2Stream_AMP3.

Sending any PAS command to A50, S50Pro no response. All have “firmware”: “4.6.9724”.

  • A30 has “mcu_ver”: “24” (“project”: “RP0011_WB60_S”)
  • S50Pro has “mcu_ver”: “5” (“project”: “RP0016_S50PRO_S”)

Can you please share with us MCU updates for the above models too?

Eh… this is the old model, it has different commands… I’ll prepare a document and release on


I am also having a problem with the firmware and the 4STREAM app. How do I update the firmware ?

Site is missing, only Building

Hi, please send me a mail ( with the output of this link for your not updated devices:
http://device_ip/httpapi.asp?command=getStatusEx, so I can check the reason why no updates

What is the command for this addition to the API?

1 Like

I have same question,i was looking for solution couple of time here,at least make some firmware with that option,i never have amplifier with this anoying beep,also volume up and down have strange delay when you click and hold on remote and after that start very quickly to change volume level ( non linear)

I was also able to connect with the UART Passthrough with this command to turn the beep off. I found the UART Passthrough exe somewhere in the Forum.

UPDATE: UART Passthrough link


Hope this helps.

Thank you for information,but i will wait for some easy fix in the future :slight_smile:

Can you please share with us the commands for the older model too?