Firmware Upgrade 4.2.9326.24

Bug Fixed:

  1. Fixed, the current volume is displayed when switch input mode
  2. Fixed, frequently switching mode on S50Pro+, and it will display 00 on the screen
  3. Fixed when changing to USB mode from Line-in mode, sound from Line-in still available
  4. Fixed, when disabled SPDIF in ACPWorkben and factory reset, there is still OPTICAL mode in APP
  5. Fixed, when grouped multiroom, the master unit has unexpected max volume.
  6. Fixed when disconnected the Bluetooth connection to connect another mobile, that mobile connection cannot be disconnect by long pressing the RESET button.
  7. Fixed when import configuration settings in ACPWorkbench will cause volume gain raised a lot.
  8. Fixed when changing mode from USB Mode, cannot use remote controller to switch back to USB mode.
  9. Fixed BLE WiFi setup fail, when the router password contains special characters.
  10. Fixed during BLE WiFi setup, BLE will disappear after waiting for a while.
  11. Fixed EQ will change to -2 when APP is closed and reopen again.
  12. Fixed when AMP2.1 ungroup from multiroom function will cause sub channel to have no sound.
  13. Fixed when connect to Windows 7 PC as USBDAC, will jump back to USBDAC when try to change to use other audio output mode on PC.
  14. Fixed S50Pro+ when idle for a while, the display will not display mode changes.
  15. Fixed AMP v3 using Volume Knob Expansion board cannot decrease the volume.
  16. Fixed, system might crash and reboot when power off
  17. Fixed, ACPWorkbench LR Swap status mismatch with actual status.
  18. Fixed the pop sound when power on Up2Stream AMP SUB

New features

  1. Completed the API command on UART interface (Device specific)
  2. Add API command to disable the beep sound of remote control
  3. Improved multiroom connection, when one device is connected via ETH, and will grouped with other device for multiroom in router mode. So, the multiroom system will have no distance limitations.
  4. After music stop playing in wifi mode for 10 secs, the device will automatically switch back to the last used mode. (Default off, enable with API command)
  5. Support to configure I2S parameters on ACPWorkbench
  6. Support to remember the last loop mode.
  7. when in multiroom mode, sync the EQ settings of the master unit to slave unit.

Improvements

  1. In multiroom mode, Subwoofer (Up2Stream 2.1AMP, AMP SUB) will inform master unit current crossover frequency. (Default on, disable with API command)
  2. Can enter WiFi pairing mode with WIFI RESET in all input modes.
  3. Use AMP2.1 Bass knob to adjust the gain of subwoofer channel instead of the BASS gain. (This only take effect when no user modification with ACPWorkbench)
  4. When WiFi module is mal-function, the device will not automatically change to Bluetooth mode.
  5. Sync the EQ settings with remote and 4stream App, only knob support precise adjustment.
  6. Deepbass can be actived by ACPWorkbench.
  7. In multiroom mode, set volume of master by remote/knob/key, will also sync the volume change to slave unit. APP can adjust volume separately for each unit.
  8. Close the 12V trigger on S50 Pro+ when no sound is output.
  9. When add gain on treble and bass, add a negative pregain meanwhile. To prevent the distortion.

Download UART

2 Likes

Where can I download this update?

The update are pushed to OTA server, and device will always be updated to the latest version. And we normally don’t give the firmware file directly.

1 Like

I understand what you just said, but I’ve noticed that it takes a long time to get updates to the devices. Anyway I’ll have to wait for the update, thank you for your response and support.

New API commands are also available in HTTP api or only UART?

Can you please give us a hint on now to send commands to the device?

Executed command:
MCU+PAS+message:param
Always getting result:
AXX+UNKNOWN

What is the correct syntax?

ok sure, i’ll prepare the documents in one place and share it

Hi, do you have the documents to share with us?

This is a documents prepared before, and you can refer to it at first: http://developer.arylic.com/download/SA50_TCP_API.pdf

We already got this from you, but it’s incomplete, because it does not cover the complete commands set as described in api-info-UART.xlsx.

Please give us information on how to syntax the commands from api-info-UART.xlsx. because the result is always AXX+UNKNOWN.

You need to send MCU+PAS+RAKOIT:{message:param}&, for example to query current version, you need to send MCU+PAS+RAKOIT:VER&.
btw, you could test with the UART tool in the first post

In the first post there’s no tool, just a list with commands.

I tried MCU+PAS+RAKOIT:VER& and the result is AXX+UNKNOWN. Firmware is 4.6.9724. Tried on Up2Stream_AMP3, A50, S50Pro.

I know I send commands in correct format to port 8899 because MCU+VOL+GET returns AXX+VOL+017 which is true (volume is indeed 17). Also MCU+PLM+GET returns AXX+PLM+010. Similarly MCU+DEV+GET returns AXX+DEV+INFmySSID;release;Up2Stream;;0;0;0& etc…

It seems PAS commands don’t work.

sorry, I thought the link is the tool :rofl:
please use this

Thank you now it works, but only with Up2Stream_AMP3.

Sending any PAS command to A50, S50Pro no response. All have “firmware”: “4.6.9724”.

  • A30 has “mcu_ver”: “24” (“project”: “RP0011_WB60_S”)
  • S50Pro has “mcu_ver”: “5” (“project”: “RP0016_S50PRO_S”)

Can you please share with us MCU updates for the above models too?

Eh… this is the old model, it has different commands… I’ll prepare a document and release on developer.arylic.com

Hello

I am also having a problem with the firmware and the 4STREAM app. How do I update the firmware ?

Site is missing, only Building

Hi, please send me a mail (frank@arylic.com) with the output of this link for your not updated devices:
http://device_ip/httpapi.asp?command=getStatusEx, so I can check the reason why no updates