Firmware update 4.6.509530.43

Today I received a new update on my HD DAC, 4.6.509530.43.
The update went OK.
do we have a changelog with bugfixes and new features?

Still cannot connect via IP address, or do I need to set something to make this happen?

Hi John,
I agree that the log page should be updates with info re bugs and fixes.
My latest HD DAC has just updated to .41. No idea why it is behind yours.
Sorry, can’t help re your IP issue.

if you mean you cannot connect to a web page using the IP Address the reason is simple, there is no web port (80 or 8080) on the HD so there is nothing to connect to.

Im on the same level of software as you.

Hi John,
I switched the replacement HD off last night and it is now bricked. This is the second unit I have had that had bricked.
The other unit I have is running .43 and seems to be fine.
The bricked unit had been running .41
It appears to me that .41 is “broken”.

Did it brick after update to 4.6.509530.43??
Or is it an not updated board?

Hi John,
Sorry, it is all a bit confusing, here is a fuller list.

  1. The first board I bought, almost a year ago, bricked when trying to update to .43 from .41 It was returned and replaced under warranty.
  2. The replacement board was running .41 and has been successfully updated to .43 It runs fine.
  3. I bought another board as “insurance” incase anything went wrong again.
    When plugged in it prompted an update. I did this yesterday and it went to .41 and not .43 as expected. I have no idea why .43 was not offered. It worked ok for a few hours and then when powered off/on it was bricked.

I have now gone back to running board 2 and it seems fine. I have contacted Arylic for additional warranty support.
Hope this helps.


I have learned a bit more.
I have been using an XP ECL10US05-P 5v2A power supply.
It appears that this supply may not be able to supply the peak current that the HD board draws during a re-flash.
I hooked board 3 up to my desk power supply that is able to deliver 5v5A and the board started up as expected. It then seemed to go through a full reboot and works as expected.
I then went back to the XP supply and it starts as expected.
I have contacted Arylic directly with these findings.
It seems (to me and not confirmed by Arylic) that the board needs a lot of current when updating/rebooting/flashing. The desk supply did this and now that this is done it then works correctly.
Maybe this explains the inconsistent results that some others were getting as well.
It is still running .41 though and no offer of an update to .43 seems available.
Anyone else have any thoughts here?

Hi Martin,

what is the full version number?
with .41 @ your side
By the way I did not power off yet after the update to 4.6.509530.43
the firmware when I received is was also a .43… 4.6.437434.43

Hi John,

The one I have that seems to work consistently is running 4.6.509530.43
The later one I have just received is flaky and is running 4.6.509530.41 and does not seem to want to update.
The .43 one seems to power off and on OK.
The .41 one often fails to start but if left powered up it eventually comes to life after a while (an hour or so with power connected).

It would be great to get some real feedback from Arylic here.

I think I have now found why the product does not boot.
It is temperature related.
My workshop is cold, 15C, and the unit fails to start. Put a hairdryer on it for a couple of seconds and it starts fine. This may explain the random performance I have seen.
If left connected to a power supply, when cold, you can see a pulse of current that then switches off and on. The board does not boot. But after a while this energy must heat the board enough and it eventually does boot up.
Some feedback from Arylic, rather than just returns, would be very helpful.

with the first HD DAC I had it updated and was partly dead,
it worked on digital in an out but the analog in and out did not work, also the bluetooth did not work.
I measured the power on the board there was no power on the bluetooth pins on the board but also not on the + and - 12V I measured 0 V
It reacted on the remote control, and it played internet radio and spotify
I left it on a day and a night but this did not result in a complete working unit
the replacement I have now works fine!
When you are right with the temperature there could be a bad serie of components in the power circuit.

I indeed mis the tech guys of Arylic in these discusions.

From previous experiences I have found that the application of heat to a board to make it work is quite often related a a bad solder join, or dry join. I’m not saying that this is the problem in your particular case.
You could try applying some slight pressure to the board/components with a non-metallic object (chop stick or similar) and see if you get the same result?

Hi Steve1 and John,
Agreed. Probably a dry joint somewhere. It is at the network end so I am not going to investigate any further. I am awaiting a return approval.
Poor QC and testing it seems.

You could try removing and re-plugging in the Linkplay sub board, one of the pins might have a bad connection.

Hi Steve1,

Good idea. Have just tried that. Didn’t take it off, just levered it up a little then pressed it back down.
Still dead. It is likely that it is a poor solder joint on the Linkplay as it starts when the heat is directed at it.
For now, not going any further and will wait on the replacement.
Thanks again for the input.

You’ve done a lot of work for the debugging, and sorry for all the mess. I’m actually also confused for this issue in the beginning, and now seems we could have some conclusion. The current drain on boot seems the most possible reason, and also the soldering loosed.
Regarding the firmware part, we’ll make some change to improve the sequence on boot. The 12V step up power will consume power very much when activated and might cause 5V drop lower and cause system reboot. So, the solution is device will turn it on boot, so the dropping pulse won’t affect too much, because the process will be very fast and the capacitors won’t release in this time and will help to supply enough current.
I just tried to supply power with a standard PC USB port which only supply 500mA current, and the board booted fine. I think it would be solved.

Regarding the changelog, that’s a good point that we did not well. Just too much work ahead and ignored the document work :crazy_face:

Hi Frank,
As I have learned over many years it is often faster when you go slow!
I suspect you have many disappointed customers due to the shortcomings here.
Please ensure that the replacement board I am being sent is flashed up to date before shipment.
I have already upgrade the power supply in my product and hope that the next steps are a bit better.

Hi Frank,
The initial replaced board I have is now offering an update to .43. It is currently running .41
What do you suggest? I currently plan to wait until my replacement of board number 2 arrives before I update as I am understandably concentered that an update to .43 may not go well.
If and when I do update it and it bricks, what will happen?
So far I have updated two and two have bricked.
I do hope that the board being sent is already updated and tested as requested.