After updating the latest firmware for Up2Stream HD DAC - Airplay 2 wireless Aptx HD its not longer working.

Before this upgrade everything worked fine.

I had no power cuts while flashing. After handling the startup, the message appears in the app “unexpected error”

I have checked: - power supply 5 volts “ok”

  • ip address is not there

  • not a single LED flashes

  • Pressed the switch 3 times for factory firmware does not work

Expect to need to flash the unit again

Please feedback on how I can get it working again.

Everything worked properly and now with this update the audio board is broken. Can’t understand how this could happen

Hi there NLY100313,
Check out this thread. Just updated my UP2Stream HD today and it is now dead!!!!! - #27 by MartinD
You are sadly, not the first to be there.
Not sure why the update hasn’t been pulled as this happened to me a few week ago.
I now have my replacement board as there does not seem to be any way of re-booting it.
They new board says an update is available…think I will stay away from that for now.
Sounds like deja vu all over again :wink:

Hello Martin,
I’m a little behind you, a new board is also sent to me.
was your first pcb also from the first batch when the new product came on the market?
I do understand that they still don’t know why this firmware is causing this.
I also think it makes sense to no longer make the latest version available.
but it may be that so far not so many sound cards fail. we wait to see what causes it now

Hi nly100313
Yes, my unit was bought the week the unit was launched.
I am still concerned by the lack of information regarding whether I should update the new unit that I now have. It seems to have a production date of 2/Dec/2022.
Does anyone from Arylic have any comments here pls?

I’ve had exactly the same issue with the board. If you are still in the warranty time you should request a replacement. My new board is already on the way to me.

Generally I think Arylic should do something generous to its customers and replace defect boards. Especially when I see the number of defect reports here in the forum. It seems their engineers have failed testing the new firmware.

Hello, two/tree weeks ago my board upgraded automatically with a message on app.
It is still working.