Blinking red LED on 2.1

Good day all,

My 2.1 amplifier has developed a bit of a problem where it is just blinking it’s red LED and doesn’t do anything. It was working just fine yesterday but now I can’t seem to get it to do anything. Have tried unplugging it completely or resetting it with the little button round back. Nothing seems to work. Just the red LED off for half a second and then back on for a second. Any help would be greatly appreciated.

Cheers, M

Hi Marijn,
Have you tried pressing the button three times to restore the factory settings?

Good day Steve,

I just tried that but it also doesn’t seem to do anything.
I’ve tried leaving it unplugged for a little while to see if that helps but to no avail.
Hope my unit isn’t bricked.

Gr M

You could try plugging in an ethernet cable and see if the white light comes on, if this happens, :crossed_fingers:then the device is connected. Then you can open the 4stream app and restore to the factory settings that way.
Go to Device settings - Speaker info - Restore factory settings.

Hi Steve sorry for getting back to you this late. My internet connection crapped the bed and I was without internet for quite some time. I’ve got the little 2.1 in front of me now connected to the modem with an ethernet cable but it just continues to blink red like before. No white light unfortunately. When I open the app I do see the soundsystem but I think that is just from setting it up. Gave it the command to reset to factory settings but it just gives an error. Tried updating firmware but doesn’t do anything either.

Thanks for all your help.

Kind regards, M