Arylic S10 remote codes not decoded correctly in current firmware

I recently purchased an Arylic S10 - and placed orders for some more DIY Audio boards.
The S10 works well using the App, but I’m having problems with the IR remote control.

I automate my Audio/Visual gear with a Logitech Harmony Elite remote and hub.
In that you can define ‘Activities’, for example a single press on the Elite LCD screen will:

  1. Turn on the Tv and select the correct input (say the Humax Satellite DVR)
  2. Turn on the Humax DVR (Humax HDR-1100s) and tune it to the correct Tv channel
  3. Turn on my A/V Amp (Denon AVR-X4500H) and select the correct HDMI input

This works very well and saves having to use half a dozen remote controls strapped together…

I was pleased to see that the Arylic S10 was supported in the Logitech database and quickly made a new activity to play music files from a USB stick plugged into the S10.

But I quickly found that IR commands sent from the Harmony Hub turned the S10 on or off.
Specifically the LG Tv and the Humax HDR-1100s ‘Power Toggle’ button.

I recorded the IR codes sent by the Harmony Hub and the LG & Humax and found the codes sent by both are identical.

Arylic Remote PowerToggle IR code BF408989
LG Tv Remote PowerToggle IR code F708FB04
Humax HDR-1100s Remote PowerToggle IR code FF001000

Looking at the ‘IR Remote Control Code’ download published on the Arylic website, shows that the LG and Humax codes are very different from the S10 codes - so why is the S10 interpreting these codes as on/off?

I then started ‘playing’ with the S10 remote and found that multiple button do the same thing - most are consistent, a few are erratic…

Specifically these buttons pressed on the S10 remote do the same as the Power Toggle button, in that they turn the S10 on/off: USB, Vol+, Previous, OPT In, Bass+, Bass-, 2, 6.

This is a major headache for me as it is causing my Harmony Elite Activities to turn the S10 on/off when ever it turns on/off the LG Tv or Humax DVR.

I conclude that the current firmware in the Arylic device doesn’t decode the IR code fully, causing multiple keys on either remote to turn the S10 device on and off erratically.

Anybody got any advice/ideas?

Hi, The S10 use NEC protocol to receive IR signals and only recognize code end with 0x8989. But since you have this issue. I suspect your remote hub emitted some extra code beside the code to turn on/off the LG TV. You can verify it with the real LG TV remote. And see if it can also control the S10.

I have verified it with the LG and Humax remote controls on their own (as I said in the post) they both turn on the S10, usually with the second PowerToggle button press:
LG Tv Remote PowerToggle IR code F708FB04
Humax HDR-1100s Remote PowerToggle IR code FF001000

You mean press USB button on remote of S10 also toggles the power of the device? That would be a problem device, you should request for a replacement.

Btw, is there any lighting interference in your environment?

Thanks for the suggestion/reply.

Yes the S10 turns on.

Just to be sure I reset the S10 to factory defaults and re-registered it to the Android App - that wasn’t straight forward (why is App so awkward?) but got there in the end.
I drew the curtains and made sure there wasn’t sunlight or other interference and this time the S10 and it’s remote behaved differently.

Pressing the USB, Vol+, Previous, OPT In, Bass+, Bass- keys still turned on the S10, but some required 3 or 5 presses of the buttons.

My Harmony Elite Activities still turned the S10 on…

I can’t see how the S10 could be faulty - except maybe the IR receiver opto chip…
I bought the S10 from Amazon UK and I have a few more weeks until the return window closes - but I will (reluctantly) return it for a refund if this issue isn’t resolved or I get no help from Arylic.

But I’ve also placed orders with Arylic for an Up2stream Amp 2.1 and a Up2stream Pro V3 plus other bits & bobs.
I thought these were shipped from the EU, but I’m now suspicious they are coming from China - so I’ve no idea how long they will take to arrive or if they have been sent…

When I started this forum post I emailed their ‘Customer Service’ ( about this problem and a link to the post - but I’ve had no reply.

Has anybody had any technical help from Arylic?

Some IR receiver might be interferenced by luorescent lamp, please check this. And if no, then might be affected by some part on the PCBA, and you can request for a refund.

Btw, I’m Arylic stuff, we received your mail indeed. Since you posted in the forum, so choose to discuss here. And for your order of the boards, normally will be sent directly from EU stock.

You should have said - how was I to know?
I know about fluorescent lamp interference, but this is in daylight (LED lights at night) so I can rule that out.

I have 2 orders with you:

  1. Order #5951 which I have received no tracking info on.
  2. Order #5999: On 31.05.2021 I received an email ‘A shipment from order #5999 is on the way’
    The tracking website shows:

    So that one is from China and according to that it hasn’t moved for a week…

I am very reluctant to return the S10 for a refund and buy another as I (supposedly) have units ‘in transit’ that perform similar functions.
Perhaps you could ask your colleagues in sales where my orders are?

Order #5951 just arrived - so that was sent from the EU.
Now I have the Up2stream Pro V3 I can see if that behave the same way as the S10.
Post test results later.

Well that didn’t take long.
The results are the same with Up2stream Pro V3 - but then I’m not surprised as the S10 probably has the same board and firmware - the size is consistent and the connectors are in the same place…

I tried it first with the supplied firmware (couldn’t find a way to the Speaker Info page) then I re-started it and upgraded the firmware to 4.2.9326.27 build 20210226.

Same result - pressing the USB, Vol+, Previous, OPT In, Bass+, Bass- keys still turned on the S10, but some required 3 or 5 presses of the buttons.

I don’t want to use the App, I want it to work correctly using the IR controlled by my Logitech Harmony Elite.

Perhaps someone at Arylic should try using their supplied remote?

Will check and reply soon

It’s weired that I tested fine with a S10 device (4.2.9326.27) and Arylic RC. All remote keys behave what is supposed to.

I’m not sure what’s happening now. Since 2 devices have the same issue, it should not be a problem on board. What adapter are you used to power up the device? Maybe interference from power…

I’m using the 5v USB adapter supplied with the S10 - and the USB lead as supplied.
Did you keep pressing the buttons?
Sometimes it needs 3 - 5 presses before the Arylic device switches on.