Amp V4 power on problem

When I apply power to my AMP V4 board, it is like the power-input of the board is short-circuiting. It brings the voltage of the supply down to 3-4V and force it into current limiting. I have tried with both a laptop supply (19V DC) and a lab-psu with 12V DC. Same for both of them. Almost like the protection diode is mounted the wrong way around. Used the DC-socket for both supplies.
Just got to play with the board, so it have never been “alive”. Any good ideas ?

Small update. It is V3 I have and not V4 as previously stated.

I applied power (5V) to the usb-input only and it fired up on all cylinders; connected to my network, renamed it, updated the firmware and it connects to my Spotify connected, but will still not take power-DC.

Maybe i ask stupid question :slight_smile: do you put another power jack to laptop power supply becouse contacts are not the same + and -

Aha you put dc socket, sorry :slight_smile:

It should be something wrong on the Power/AMP part if you can confirm the polarity is correct. If it has so large current, the broken part should have been burned out, maybe can check the PCB to find the place.
Btw, the USB connector only supplys +5V for the player part, the AMP won’t work with it.

Dear Frank
Thanks for your input. I have confirmed that the polarity is correct. I have also done a visual inspection of the board, but I can’t find anything wrong, like a burned out component. However, I have not yet looked under the heatsink.
I am aware that the +5V is only for the player part. Just wanted to to see if the board was completely dead. I understand the the AMP-part will not work with that

Also you can try to remove linkplay a31 module and try like indipendend amp,i try my v3 amp without linkplay board and work like power amp…with line in source .