Amazon Music

Hi wondering if anyone can help me out I have just got a A50+ set it up but can’t get Amazon music to work have entered my details can see my music but when I try to play I get nothing any help would be appreciated thanks

Does anything work?
can you play from your DLNA server or from USB?
Do any of the radio apps work?
what is your controller (Iphone, android)?

Hi I can airplay to it and internet radio works not tried anything else yet. I’m using IPhone thanks

So at least we know that its not an Audio issue. What’s your Amazon License? it could be that your only allowed to play one one device at a time but the Acylic app should pop up with a message giving you a warning.
i would also try deleting the 4stream app and reloading it and redo your Amazon Account when it restarts (just to be safe make sure the Amazon Music isn’t playing anywhere else, so that your device has priority access).

I have Amazon music prime can play it without issue on other devices I have tried deleting 4stream, factory resetting A50+ deleted access on Amazon account and registering it and still having issues. No other devices are playing music and I even deleted all device access apart from A50 to make sure. I’m at a loss I think thanks for your help

I think it is an app problem I have just downloaded wiim app and it works fine so I’m assuming it is a 4stream issue :thinking:

Sorry I cant be more help, my system connected without issue to Amazon and posts a warning if I try to run it on another device (I’ve only paid for one access at a time).
Try setting up a free Spotify and you can get some free tunes until this Amazon Music gets sorted.

Reflashing the system software via the pc tool connection by usb may be another thing to try

There is a similar App called Advanced Playstream it too is based on the same Playlink pcb in your system,

Thanks for your help :+1:

I’m having similar issues using Android. I did try the Advanced Playstream app as well and it behaved similarly.

Amazon portion opens fine but when I select a category it just skips through all the songs and then stops entirely. No audio is heard at all during this.

I can hear IHeart Radio just fine

Well I’ve had ups and downs with these streaming services (Amazon and Napster). As of now it is working. I’ve switched to a LAN and it’s working. Not sure if it takes a while to settle after a power up or the WiFi was affecting the connection.