ACP Workbench won’t connect to Up2Stream Plate Amp

My ACP Workbench won’t connect to my Up2Stream Plate Amp.

I have the latest ACP software, a recent Plate Amp and I used the provided USB cable. Using Windows 11.

I run the S/W, plug in the provided cable but the LED never goes Yellow and the ACP never connects to the Plate Amp.
I can’t reconfigure the USB Port settings in the app…
I tried a different USB cable (from a printer) and that made no difference.
I rebooted the PC . I rebooted the Amp.

The Amp seems to otherwise work.

Is there some incompatibility or a trick?

Pretty unhappy that it’s not connecting.

I did some more testing.

According to the manual, the LED Indicates different input source of the device.

White for WiFi.

Blue for Bluetooth.

Green for AUX.

Yellow for USB.

Pressing the volume button goes, white, blue, green only. NO USB. This happens whether there is a computer connected to the USB input or not.

My Plate Amp firmware is 4.6.415145.37 build date 20220427

I assume the unit is defective in some regard.

The USB mode should work with Win10/11 directly. If the cable the USB port is fine, I guess it might be problem in the board, could consider to request for a replace.

I have requested a replacement. Would they test it before it was shipped out?
I hope that also resolves the problem with ACP Workbench as well.