ACP Workbench fails launching

I have recently installed ACPWorkbench on my Windows 10 @ 64 bit laptop.

The installation process went perfectly well without any trouble or error messages but unfortunately I am not able to start the program; nothing happens, does not even come to the point where I am supposed to enter license code and only sign of life is the window below showed very briefly.

I have checked that the .NET framework 3.5 is installed and have tried to uninstall, reboot and reinstall without any luck. Have also tried installation on another Win 10 PC (desktop workstation) and this actually works… but I need to run the sw from the laptop… (Yes, I know that I cannot use the code on two computers - but that is certainly not the reason for the issue)

Does anyone have similar experience or some hints that can help me on the way.

Thanks in advance :slight_smile:

1 Like

Same here.
Have tried running as admin / run elevated, but the Arylic logo appears/disappears, nothing more seems to happen.
Did you figure out a solution?

1 Like

No. Unfortunately I did not find any solution other than moving to another (desktop) PC…

So I gave up :frowning:

1 Like

Can we bump this? I’m an integrator and put these in systems as an alternative Sonos. I paid for the tool to help wow the customers with room corrected audio but it doesn’t launch.

1 Like

Hi, I have the same isue on Windows 10 64bit LTSC version. Anyone?


1 Like

Add me to the list.
Windows 11 here though. The Arylic support team were not helpful as all they could do, besides provide a Chinese version of the tool (which did launch but failed to activate with my license, and they didn’t provide a different one to test out), was tell me the tool ran in their computer.

My machine is a high-er end Core i7 1185G7 (11th Gen) with 32GB DDR5 and a 4TB nvme. I’ve attempted every combination of “compatibility” modes, admin privileges, etc. I even formatted my machine, hoping there’d be a difference. Nothing.

Short of hunting down a used laptop in Marketplace JUST to run this thing; and even then, there’s no guarantee that’ll work.

I’m out of ideas, and just like @CvLewis, I’m also offering these professionally, and was looking forward to using the DSP. I’ve spend close to $5,000 in Arylic equipment in the last few months and they can’t seem to be able to handle people using modern computers to do adjusting. I’m pretty disappointed.