Access over USB from Windows?

Maybe I got something wrong: Is there a way to access/control/setup the Up2stream Amp V4
via Network /USB?
T&he picture says I can connect the Micro USB to a PC, but how? Driver? Possibilites?
And over the web?
tks in advance

When connected the device to PC via the micro USB, it will behave like a USB sound card. And it should be driven by default, so you should find a new audio device without any other operation. When selected, all PC audio will go to the board.
And when connected with USB, you can run ACPWorkbench on PC, and configure the audio parameters (Gain, EQ, some DSP algorithms, PIN functions, etc) of the device and download to device for next boot.

I try to connect it to a Raspberry Pi. What DAC is used in the up2stream V4?

OK, Managed that.
~ $ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: Audio [Up2Stream USB Audio], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0

Changed the /etc/asound.conf to:
**Set default mixer controls
ctl.!default {
type hw
card 1

**Set default PCM device
pcm.!default {
type hw
card 1
and now it runs well! Good
Its an old RaspberryPi 2B (26 Pin GPIO) with a pretty good mpd Webradio installed
that is now booming over up2stream V4.
Now the question is: How to divert the Radio stream from the Raspi->up2Stream to other Devices from Arylic over the Net?

when you play via the USB AUDIO on AMP V4, and could connect other device to this AMP V4 board to group a multiroom system, and all the devices should have the same audio .

Thank you, managed to do that. I play sound over the inbuilt DAC from a Raspberry Web Radio/Streaming server.
I managed to stream this Multiroom (welll, 2 Rooms now). The only thing is when I switch everything off, I have to pair the devices again and declare Master and Slave. Why is this configuration not saved?
And-as soon as I play something else at the Up2Beat inbuilt Channels (USB Music, Inbuilt Web Radio, Airplay etc) I have no chance to return to stream played over the DAC by the App. There is just no button there to do that. Only when I rotate through the Stream Channels by short pressing power button and return to the white light-the DAC Stream plays again (in my case the Raspberry Pi attached to the Micro USB Port using the Up2Stream Dac). Very annoying! Why is there no button in the app to do this? And if you are on it, add a button for Airplay and WiFI as well!
I might note that the use of the app is very inconsistant and complicated! (Thats why I attached my own Webradio via a RasPi Zero to the Up2Stream). I somehow managed to install and update a second Arylic device (Mini Up2Stream V3), but I really dont know how.
(might note that I am a retired IT engineer). Seems that the options and menues appear by luck. The second device allways said: No Internet connection, and after several resets and newstarts it somehow connected to the internet and started Firmware Update.

I consider the Devices as good solid hardware, but the Software is inconsistant in its use and faulty and somehow you need luck to operate it and get to the needed results.

I installed a USB-to-Lan Remote Port Server on the attached RaspBerry, so I can access the Up2Beat via ACP Workbench over the web with my windows Computer. (And by the way stream Music to the Up2Beat by any application from my PC that uses a Sound Card, her the virtual one that is established via USB-LAN Server on the Raspberry)

I should have read your feedback on APP, and for the USB DAC mode, we’ve added a standalone source for it, so you can switch to it on APP now. And we also improved the multi-room part, the device will now try to group together when powered off and back on. We’ll keep on working to improve the software.
We’re now still testing the firmwares, should be almost ready, will release asap when finished.

Keep on the good work! Thanks. I am a fan of your devices and try to help. So, there is a new app?
I might add that I constructed the Webradio not myself, its by Bob Rathbone, I just extended it to have a display at the Amp to show me the channel, display RSS Feeds over that, Date, Time and some other things, buttons to change channel and Loudness, Shutdown aso and mainly to add speech cpability for blind people that SPEAKS and Calls the Channel and someother things)

Something very funny. The Volume Knob Board disables the DAC on the Up2Stream V4.
And it only works in Volume +, Not Volume - —but: what comes up, must come down?!

In the picture you see: first the Volume knob was not attached.
Device was powered off, then Volume Knob attached, Powered on again.
No more sound coming over the DAC, its not existing any more (no soundcard found)
Is this supposed to work like this???
Tried it out several times-allways the soundcard (DAC) vanishes after the Volume Knob is attached.
Seems like the Volume Knob board monopolizes the DAC-not nice! Why doesnt it work like the Remote IR Control? Volume Up/down -no problem.

Very strange problem, I know some other users have the same issue that the coding key knob has only Volume+, but I can’t copy this problem on my side, so have no idea but a hanging issue.
And do you have a multimeter to test the coding key knob? Test and see if the 2 PINs are not short to GND in normal condition, and see if it can be short to GND when rotate.
The coding key knob should have no connection with the USB part, the only reason I could imagine is that the PINs are short to GND and cause some problem on power.
And another point to check, try switch to USB mode and see if it recovers.

SORRY ! Was my mistake I should have read the Manual (RTFM). My Apology!
There where 2 Cables attached in the Set, I connected both to the board.
Now I read in the setup manual that only 1 is used according to the Amp used. In my case, the smaller one.
Now it works perfectly. But I realized a mistake in the Manual

The picture says

  1. For Amp 2.9 V3/Pro V3 Pro v3
  2. For Mini V3

The text says

  1. Connect to Mini V3
    2.Connect to Pro V3 / Amp 2.0 v3

Should be the other way round?

ah, got a bug in manual… you should follow the silkprint on board, connect the 4PINs only for PRO.
thanks for pointing it out. will update the document. maybe we need to maintain a digital copy of manuals somewhere, so users can check the latest online.

1 Like