Bug with Up2Stream Plate amp?

I have three other Arylic products so am pretty sure that this is a real bug as the rest all work correctly. I have just started using this plate amp and the first time I used it I upgraded the F/W to 4.6.415145.35. It worked as expected but then after a power off there was no sound when re-powered. The product worked as expected on the app…just no sound. After a few (many) power cycles it did play sound but again, after the next power cycle it was silent.
I then tried the “Restore Factory Settings” reset option and it played sound as expected.
After the reset and reboot it still displays the F/W as 4.6.415145.35. Is this expected?

I have also noted that if you leave it powered off with no mains connection for a considerable period then it does play audio when powered up again.

Do any of you have any ideas?


I have also experienced this issue with the Plate Amp.
I however only got the amp yesterday, so it was just something i noticed when testing it but it happened 3 times

Hi Jonas,
Looks as if it is a bug then. We just need to wait until Arylic pick it up. All the best.


In general, I’m quite reluctant when it comes to upgrading the firmware of Arylic products. If the firmware works for my main use cases I will freeze it. It seems that sometimes we are considered as beta testers of new firmware versions and I don’t want to make my audio system inoperable until the “day 1” bugs are fixed.

This said, I might have run into the same trap with my new plate amps because I usually upgrade the firmware once when I get a new product. Hope that at least the “old” firmware version that comes with the amps does not have this bug. Thanks for sharing this information.

Best regards,

Hi all,
An update has now been made available. It is 4.6.415145.37.
This fixes the issue I had.
Many thanks Arylic.