B50 not resuming ARC

I just received my B50. The HDMI ARC volume feels a bit low but still acceptable when cranked to 80-90%.

A complete deal breaker for me, however, is that when I turn off the TV and turn it back on, the TV output does not always switch back to ARC.

The TV is a Hisense U7H with latest firmware.

I’ve had a Yamaha soundbar connected to the TV prior to this via ARC, and the soundbar functioned perfectly, coming out of standby when the TV turns on and allowing the TV to resume output via ARC.

It kind of feels like the issue is with the B50 completely shutting off all interfaces when it enters standby and when the TV turns on again it doesn’t sense the B50 on HDMI. I validated this assumption a bit by force waking the B50 prior to turning on the TV, at which point the TV recognized the ARC output and had no issues.

When I don’t force wake the B50 prior to turning on the TV, there is no audio for a few seconds, then the TV shows a device was connected via HDMI (B50 wakes up) and then a few seconds later it switches audio to ARC output (when it works anyway). Some of the times it doesn’t switch to the audio at all until I manually tell the TV to start using ARC again.

Can this be fixed via a firmware update? If the B50 can’t go to standby without shutting down the HDMI, can we get an option to disable the standby behavior?

Hi, the device is meant to wake up following TV, but seems something wrong with your TV model. But sorry, I can’t fix this issue easily without the TV.
So your last suggestion would be an option. I’ll build a firmware, and you could long press ARC button on remote to disable the CEC power on/off feature. Hope this is acceptable for you.

The B50 does wake up following the TV but does not do so fast enough before the TV seems to change to its builtin speaker.

The TV has a popup it shows when the B50 starts back up, saying it detected a device on HDMI. When I was using a soundbar, this never happened, the seemed to always be connected even while in standby (based on the fact the TV didn’t pop up the notification after turning on).

Being able to disable the CEC power standby would be great.

Is there an estimated eta for the firmware update?

Hi, you could upgrade this version firmware

  • You could long press the ARC button on remote to turn OFF/ON the auto standby feature.
  • Besides, long press the PHONO button on remote, could switch between MM/MC mode. Btw, normally, it works in MM mode, and when switch to MC mode, the device will just apply a +10dB extra gain over the phono input.

To upgrade B50 model:

  • You need a USB disk with format FAT (not FAT32 or exFAT for now).
  • And copy the firmware MVA file into the disk root directory (note: you need to delete any other MVA files), then plug the disk into B50,
  • And then double press the front knob quickly (double click).
  • If all goes well, all LEDs of B50 will light up which indicates the upgrading begins. And will turn to normal when finished.
    Please do make sure don’t cut power in this process, or it will brick the device.

Same issue here. I bought the B50 to replace a Denon AVR-S540BT. I’ve used it for 3 years and never once had an issue with ARC or CEC, but with the B50 there is about a 50% chance I’ll get audio

My issue seems different to yours, so I’ll post it here just incase anyone has a similar issue. Its a Sony XBR-55X850D and when I turn it on, it will display “Switching to TV speakers” and then “Switching to External Audio”, but for whatever reason, most of the time there is then no sound through the B50. I have to switch back to internal speakers via the menu and back to external, which most of the time fixes it.

Testing turning the B50 on first seems to fix the issue, but that doesn’t really seem like a solution to me, as I want a single remote experience.

Tried updating the firmware above, but 3 different flash drives formatted to FAT32 with file on don’t seem to do anything in the B50. Tried double pressing the knob a bunch of times, different speeds, and it never lights up like described

I think we need more detailed instructions… I formatted a USB to MBR/FAT32 and copied the file as without any renaming, then I plugged the usb into the USB type A port in the back, when I do the device switches to “USB”, then I double press the volume button, and nothing happens.

What am I doing wrong if anything? Current firmware on the B50 is 48-b0ab8739-7 according to Go Control.

Do I need ACPWorkbench to do the update?

1 Like

Sorry, I made a mistake. Need to use FAT format, not FAT32.
And if you use APP, it will also prompt with firmware upgrade.

hello, is this firmware offical the newest firmware or a beta version…?

what is new in this new firmware version ( changes ,features, bug fixes and other…) ?

thank you

I was using a 32GB usb stick, and I tried both FAT12 and FAT16, neither worked.

What did work is I had a really old 1GB USB stick lying around, and when I used that, it worked immediately. I also formatted/partitioned the 1GB stick to MBR/FAT16.

This seems to indicate the device is very sensitive to what USB stick you’re using, so field upgrades via USB is not really feasible unless Arylic can provide a list of tested USB sticks.

That caveat aside, ARC output on the TV seems reliable after the update, and disabling ARC CEC standby seems to persist across power cycles on the B50, so I’ll be keeping the device personally, but find it still difficult to recommend to anyone without big asterisks on the recommendation due to the USB support problem with upgrades.

I’ll look into this… I should ever tested with a 64GB USB disk and which works fine.

I believe what you’re saying, but I think it just points to the need to publish some sort of compatibility list or known good list. Even better would be if the update can be just done through the app without a USB stick.

This Sandisk Cruzer Fit CZ33 is the specific USB drive that failed for me.

I worry about the “if all goes well” part when updating firmware :wink: What if it doesn’t go well? I hope I haven’t bricked the amp? And where do I find the latest firmware?

Haha, we’ve upgraded thousands of devices in factory actually. Should be safe enough to worry about.

Then the question is, where do I download new firmware for the B50? There may not be any but how and where do I check for upgrades? I have been checking around the ste but can’t find anything about B50 firmware.

yes, we did not officially release firmware yet. And one possible solution: user would be notified on App that there’s a new version, and then will guide user for the steps for the upgrading, or he could choose to ignore it anyway.
It’s not good experience for user to upgrade device in this way, but we did not find a way to transfer firmware with considerable time via BLE to device. So, this is the idea.


I have a situation a bit different but related with ARC. In fact after some standby / on tests from my TV (TCL - Android) and one time B50 resumed ARC but no sound - even with volume in max and also switching between fonts (moved to line in and then to ARC) . After did standby / on it come back normally.

About the situation I mentioned: its a bit annoying - maybe is a TV issue - but when I do standby, TV returns to built-in speakers with volume 100 for a second and its really annoying. I can change built-in speakers volume to 20 or 10, but next time (when I do standby - turn on from TV), volume resumes always to 100. I think it happens also when turn on TV - built-in speakers with 100 - but since its Android and I use IPTV app, this is not perceived before audio streaming really starts.

Anyone with similar situation?

Tried updating from 48, amp sees the update on usb and prompts update. Amp appears to start update with all LEDs on and power cycle however FW displayed in app never actually updates.

Any ideas?

I really want to turn off the CEC power issue.

Updated firmware via the official rollout (B50 Firmware Version Update 52-452f344c) and also updated the app, all went smoothly. There is an option to turn off ARC standby in the app. I have turned that off, we’ll see if it fixed the issue.

EDIT: after a quick test it appears to be working after having ARC standby turned off

sounds good, cheers